Any way to make Curve EQ Window open with consistent size?

I like the stock Curve EQ Equalizer insert in the mixer because of its flexibility and the way it displays the audio spectrum in real time with different display options. So I use it a lot, but every time I open it it takes up my whole screen plus it goes off the right edge and bottom by a mile. (I have a 32" 4K monitor). So I have to waste lots of time resizing and positioning it every time I open it. Is there any way to set it to a certain size and make it always open to that size? Its Function dropdown has a setting called “Allow Window to be Resized” but it makes no apparent difference.

I don’t have a problem with the plugin. It remember it’s position everytime I reload my project (Windows 11)

Try changing the HiDPI settings in preferences.

Right now HiDPI is enabled and it’s set to “Windows Scaling Setting”. What do you suggest I change it to? All the regular Cubase windows like the Track list, Key Editor, Mixer, etc, seem to be OK and I don’t want to break them. Third party stuff like VSTIs and stuff like this stock insert (by “Voxengo”?) seem to behave unpredictibly - sometimes way too big, sometimes way too small.

PS - I’m on Windows 10, Pro.

Sorry, I’m not following this . . . are you saying you have to reload your project to to get it to remember its setting? I can’t even get it to remember its setting WITHIN a project - I open it and resize it to what I want, then close it and reopen it again in the same project and it doesn’t remember what I resized it to.

it works just like expected for me. if I load a new instance - resize the windows - close the plug and open it

still same size

if I close Cubase - restart - reload project - still curve eq is the resize window and in the same position

so I don’t experience the issues you are having