Anyone noticed slow project file saving? Cubase7.5

It takes 10 or more seconds to save average-size project file in Cubase 7.5 All previous Cubase versions were much faster. It makes annoying delays in workflow - while saving (or auto-save), Cubase does not respond to anything.

+1.

You REALLY notice it when saving a project with a great many edits and crossfades, for example after quantising a multitrack drum kit. Older Cubase/Nuendo, about 12 seconds, Cubase 7.5, nearly 30 seconds. This is a serious workflow issue for me. I have to turn off autosave whilst working on the editing, and bounce the tracks after quantising.

Also, there is a performance hit on the graphics in this situation, at least on Mac. Moving a crossfade is really sticky now, even on a 3.3GHZ 6 core MacPro with Radeon 5770 1GB card.

It’s a Cubase programming issue - nothing to do with drive speed or access, I use an SSD for audio.

It’s so far for me the main fly in the ointment for what is otherwise a very solid and worthwhile new version.

Aloha guys, just to chime in.

No probs with saving using C7.5 here.
{’-’}

I’ve had the same issue since about 7.0.5 I think?

On a Mac I get the spinning rainbow and the hard drive performance light goes to max for quite some time.

Hard drive in question is brand new …

Hi Curteye

I would love there to be some fixable reason why it can take nearly 30" to save a project here.

If you have access to a project with something like live drums (say, 8-10 audio tracks) can you try quantising them using a folder track, Hitpoints on say 2 of the tracks, then use the pop-up quantise panel to slice and crossfade them, and then save and report how long it takes? Typically for me doing this produces about 8 slices per bar, so probably a few hundred in a 3-4 minute song.

It’s a big ask, but there is an issue here and I’d be very grateful for some feedback. Or anyone else who wants to try it.

SImilar problem here, just posted this the other day. I edit 2 hr live shows and don’t delegate each performed composition to a new cubase project, but rather leave it in the 2 hr timeline, 24 tracks minimum before editing and making more tracks to separate things like applause, solos/melodies vs when a track is background, etc.

saves are very long, auto saves are just as long and the program won’t save in the background, so all work comes to a halt…very disruptive. Never had this problem with 6 and earlier, it must be all the new graphics.

If it is, why can’t the save just do what computer programs usually do: if nothing’s changed except for a few things, you don’t need to do anything but update the last save’s data with the ‘changed’ info. Not everything in the windows including those that haven’t changed…(at least that’s what I’m feeling is going on, like each save is a fresh save from scratch and there’s now a ton of new graphics (hidden and not hidden depending on the views) that weren’t available in previous versions…so I’m guessing that’s clogging up the data stream when saving and slooooooowing it down). It’d be nice to have a real STeinberg person address this with the facts known to them.
El profe

I actually find 7.5 both saves and loads more quickly than 7.6. Perhaps some projects in 7.5 have more to save - ie., hitpoints on all audio, various track versions - and that this hasn’t been ‘optimzed’ yet.

Saving time in 7.5 is much longer than 7.06 for the same project (SSD disks). It’s a pity because at 7.06 was really fast. I have not updated, but I’ve done a full installation of 7.5 and I’m glad, because after a week with 7.5, I’m going back to 7.06. Do not want to sound negative. Both versions are excellent.

Yes, multitrack drums with much cuts. While 7.0.6(64bit) saves the project in 4 seconds, C7.5 (64bit) takes around 15 seconds (i.e. 3-4 times worse). The same machine, the same project. I work with auto-save period set to 5 minutes long years what is starting to be real workflow brake seriously. It simply looks like programmers added some new code into save routines or to objects handling event fades, but the code is not time effective?

yep +1
fresh 7.5 test project
on one midi track with outboard synth, kontakt with two libraries- (albion, projectsam), also GA4se running- 8 tracks in total. 6-15 secs to save.
Another ting events in key editor disappears if i mute them, happens about a couple of hours into session

+1 My save time is slowed noticeably in 7.5.

Also finding a big time workflow issue is that my Key Editor window will not open. I click on it and nothing happens. I save close and re-open the same project and the key editor window is now there but as soon as I click the red x and close it I can not access it anymore and need to close and re-open project to get it again. Anyone else?

Did you try turning off automatic hitpoint detection ? - it’s on by default.
My files grew larger and larger (and slower load/save times) until I turned it off.
Mads

Yup, slower saves here compared even to 7.0.6. 7 was already slower than 6.5.

That increases likelihood of file corruption. Any time you save or auto-save, it makes an entirely new file, so if there’s a crash while saving, you won’t be screwed if you’ve been saving iteratively and before potentially dangerous operations.

The sucky thing is, 7.5 now has file sizes at least 10x larger than 7.0.6, so saving often starts to eat up space pretty quick.

Automatic hitpoint detection does this… - your file probably already has a lot of them. Delete them and file size is back to normal :wink:

Is that a preference somewhere? It’s kinda pointless for my stuff.

yes: preferences/editing/audio
But you have to manually remove hitpoints already added.

I’ve turned off automatic hitpoint detection (not hitpoints added by the way), but saving times remain very long compared to 7.0.6.

My save time is now up to 5 min 15 sec… so those of you who have a few seconds added, you are lucky. ha!

I’m thinking it crashed, but go get a snack and eventually it comes back.

I had to turn the auto save to once an hour, even when that happens at that rate, it’s nuts.
luckily I haven’t crashed and lost work.

The cpu meter is peaking, so I’m glad it’s not crashing…but it reminds me of the old Atari 104O days…
I thought with a Mac Pro with 8 cores and 12 gigs of ram using Mtn Lion and all internal SATA drives maintained with DiscWarrior to keep directories from being less than 1 % fragmented… I’d be ok…

I am using Vari Audio to pitch a bunch of tracks, if I turn off (as madsv suggests) the hitpoints detection in prefs,
will I lose my work on the pitching? I do have lots more pitching and timing changes to do…

thanks,

el profe

No, it won’t affect Vari Audio.

Also:
don’t forget to delete all Hitpoints ( Audio > Hitpoints > ), before resaving.

Jan

+1 here too…

On my Setup a save takes about 3 times longer than with C7.06. Whats even more annoying is when the Autobackup kicks in and you’re in the middle of work. C7.5 just freezes until the Autobackup is finished.