[apparently not a]Bug: Exporting to mp3 adds silence

This one is odd: exporting to mp3 adds 20-30 ms of silence at the beginning of the file. Is this a bug or is it something in my system?

See screenshots:


This is not really a big though it is annoying.

It’s standard for basically all MP3 encoding. I believe there is some software called mp3 direct cut that would let you trim the length of MP3 files if needed.

Wow, even after doing this for many years, I’ve never noticed. Then again, this was the first time I have been tasked with making sounds with ms accuracy AND delivering them as mp3s (something to do with the sound library being used).


The weird thing is you’ll get 3 different lengths of added silence at beginning and end from 3 different decoders, not just the encoder, where I guess you get the first delay and padding. Unless it’s all in the decoders. I can’t remember.

If you decode the same MP3 to Wav in Wavelab, iTunes, and Foobar 2000, the results will all be different.

I’d be interested to know how you resolve this.

Foobar 2000 displays delay and padding properties or metadata of Lame MP3’s bought from Amazon and Google Music.

I’ll inform them, and see if it can adjusted in playback (moving the starting point). If not, well, we’ll see :slight_smile:

Thanks all,


Glad to hear it’s not just me, I just finished a 60min podcast for iTunes and noticed the mp3 version was minutes longer than the wav master file and the flac version.
Rather than figure it out, I went back to using dBpoweramp for generating mp3’s using the WaveLab master as a source. Check it out if you haven’t already - https://www.dbpoweramp.com/
If someone sends me their audio file as a mp3, I use dBpoweramp to generate the wav files used for editing. It converts all formats perfectly and at high bitrates.

Hmm. I don’t think an mp3 encode should be minutes longer that the original source. Perhaps there was an incorrect setting when the mp3 was rendered or some time stretching/pitch shifting was accidentally enabled.

Was the mp3 actually minutes longer or was some software just saying that it was minutes longer? I know there could be some false time reports with variable bit rate mp3s from WaveLab but I thought maybe that was fixed.

Hi there!

The previous silence is because of the mp3 metadata tags and it’s impossible to remove it. They are stored at the beginning of the file and it appears as a silence.

Some software like Logic Pro automatically removes this silence from the start when you load the file, but if you export the file again, the silence is still there. It’s especially problematic when you need to export a “loopable” file.

I’ve been fighting that war a long time and I couldn’t find any solution, sorry.

It’s been my understanding that the added beginning silence (“delay”) and ending silence (“padding”) are added regardless of metadata, in encode (delay and padding) and decode (delay).

Here under Gapless Playback Info:


I wonder where you’ve seen it said that the silence was because of metadata?

Also good to know about Logic, thanks.


Thanks bob99, a friend told me about the “metadata silence” but I didn’t reach a really scientific-based answer till now.

Now I can comment in forums with more information.