Appearance of bar repeat counts for first bar

Is there no global option to turn off the (2) that appears over a single one-bar repeat? Yes, I know you can do it in the properties panel. But this is annoying to have to do each and every time.

Also selecting “Do not show” in the “Appearance of bar count for the first bar in the region” menu of Engraving Options does NOT fix this. Any ideas?

There’s a global setting for the appearance of the last bar in the region, separate from the setting for other counts (ie the counts shown at the set frequency within the region) in Engraving Options > Bar Repeats.

Ahh, I get it. Technically, this makes sense. But since a one-bar repeat would also be the FIRST bar of the region, this does not seem very clear to me.