Apple Silicon - Extremely Slow Exports - Workaround!

TLDR = slow export times on Apple Silicon? Set your buffer size to max before export! This can boost your export times by 100%.

Hey everybody,

So for the past month or so I have been using a MBP 14" with M3 Max processor as my main system. Coming from self-build PC’s this has been a bit of a change, but mostly for the better. Performance is great, everything is (and stays) snappy and the machine is super portable. The only thing that was way worse compared to my old PC was the export times. These are nearly twice as slow compared to my 3 year old PC, which nearly became a deal-breaker for me.

So two days ago I had to export some stems for final delivery of a large project containing a lot of processing. The track length is 3 minutes, but the export took 4 minute for each stem. There were 15 stems in total. So this adds up to a full hour of export time, which simply said just sucks. Once the export was done, I realised I forgot to remove a plug-in from my master chain. Damn’ it! So I got to do ANOTHER full hour export.

But here comes to good news. Yesterday I discovered that the buffer size setting dramatically influences the export times. Since the MBP is so fast I was working on a buffer size of 64, whereas on my old PC I had to be at 512 or 1024 to prevent stuttering or glitches. Here are some export times with different buffer settings, I have also exported the same projects on my old PC (specs: 5900x OC @ static 4.5ghz, 64GB RAM, all M2 SSDs internal).

Project 1: a full orchestral / cinematic track with very heavy processing. Track length = 3m10s.

  • Old PC (reference) = 03m17s
  • Macbook Pro (buffer 64) = 05m40
  • Macbook Pro (buffer 512) = 03m39
  • Macbook Pro (buffer 2048) = 03m10 < this one actually was faster than the reference PC!

Project 2: A fairly lightweight mastering project, just some processing on the master bus. Track length = 3m05.

  • Old PC (reference) = 00m50s
  • Macbook Pro (buffer 64) = 01m07
  • Macbook Pro (buffer 2048) = 00m52

Project 3: Extremely Kontakt heavy project, with loads of processing going on. Track length = 5m10s.

  • Old PC (reference) = 2m35s
  • Macbook Pro (buffer 64) = 04m12
  • Macbook Pro (buffer 2048) = 02m41s

I also watched the CPU activity monitor during exports and the graphs look completely different between 64/128/256 samples and 512/1024/2048 samples.

  1. Export with low buffer size. Notice how half of the performance cores seem to be idle:
  2. Export with high buffer size. All performance cores are active and the overall graph looks a lot more “spikey”, like things are happening in bursts:

So I’ll be raising my buffer size for now, Hopefully there will be a better fix sometime soon. I’m just glad that I can export my projects at a reasonable speed again.


I am/have been on Intel, but I noticed this too. Bigger buffers → faster rendering, but not so extreme as in your case. Logic has that too, to some extent.
UAD plug-ins that run on their hardware will often slow down rendering too.

Yup, it’s been like this for as long as one has been able to adjust buffers.

I routinely set my buffers to the highest available level before exporting. Other interfering factors include some 3rd-party plugins (UA’s non-natives grind your export session significantly; the native versions much less so).

Nuendo/Cubase stock plugins tend to be very good and reliably fast-- a handful of us here on the forum tend to stick with them for that reason.