Apple trackpad laggy and slow in cubase.


I am trying to use the trackpad in cubase. But suddently editing is so slow and laggy…
Lets say I want to copy som audio. When I use the "alt"key and drag the bit I want to copy I have to wait at least a couple of seconds before I release the trackpad to be sure it actually copied it and no just moved the clip.
Same behavior is for a lot of editing. Its like I move something, and Cubase have to “think” a couple of seconds before it realizes what I want to do.

When I use a mouse to do the same tasks its smooth and fast.

The trackpad workes like a dream with everything else on my mac. Is this a known cubase problem with the trackpad?
If so, is there a way to make the trackpad work smoothly in cubase?


No issues here on OSX 10.10.5 - yeah I know it’s “not supported” in ver. 9 but everything runs smoothly both in Cubase 8.5 & 9. My trackpad runs similarly to my Magic Mouse and exhibits no sluggish behavior whatsoever.

The problem is not that the pointer is sluggish. Everything works fine in those regards.

The thing that bothers me is when I make edits with it. Like when I copy a clip by holding “alt” and dragging it to another place. With my mouse, it copy it instantly when I release the mouse button. But with the trackpad it stops for a second or two when I release before it actally copies it. And if I dont wait, it will only move the clip from the original place to the new one. And I am used to edit pretty fast so this bothers me a bit :neutral_face:

Same goes when I edit hitpoints or are using variaudio and warp.

Movement of the pointer and zooming works just like a dream :smiley:

Still no issue here with copying audio or MIDI files either. No delay in release from altering events or hit points as well. Not sure the fix for you - sorry.

hey… i just joined the forum and posted a similar problem yesterday and only today I discovered that the problem is caused by the trackpad!! Can anybody explain why this happens? For me i realize it when I select a note in the key editor using my trackpad and then use the arrow keys of my wired apple keyboard to move it up or down. it’s like Cubase needs a few seconds to think before it moves anything. So strange. Was troubleshooting it with a friend over teamviewer today and he was able to move the notes around no problem over teamviewer so we thought the culprit may be either the mouse or the keyboard. I connected a wired mouse and it worked perfectly! I’m so glad but at the same time would REALLY like to know why this is happening. Anybody?

I had this occur to me on a different DAW and it was due to a replacement power supply that i got (Turned out it wasn’t genuine) - it was fine in everything else, very bizarre. Pull your charger out and run on battery to see if that’s your cause also. It’s a long shot i know lol