Application 'Unknown Application trouble

Cubase 12 trouble again. everytime I start it this wonderful message appears.
Application ‘Unknown Application’ has caused the following error: Application not registered:


Start Steinberg Activation Manager and make sure your Cubase 12 license is activated properly, please.

At least some system specs could help.

Maybe it is a third party VST plugin?

The activation manager states Cubase 12 -activated, the same goes for all products with e-licenser.
This started happening yesterday, and I have not updated anything for at least a week.


Isn’t it any plug-in message?


Same thing happens here, after I updated to Cubase 12.0.20. It appears to be an eLicenser Error. I reinstalled the elicenser control software, but it didn’t help. Once I click OK in the error dialog box… Cubase appears to continue to start normally. Never seen this before.

EDIT Upon closer observation, this error appears to be generated while Cubase is initializing “vstconnect.dll” during startup.

If I don’t click the OK button right away… like maybe a couple of minutes, Cubase gets stuck again and after a while I get this prompt to retry:



So you have the same problem. I uninstalled and removed some stuff( halion se standalone) And It seemed that this helped, but today I got the same message again, only without your second message
regards Stojan.


nope, in my case it mentions e-licenser, but if I run it, everything is ok.


Install the latest VST Connect update, please. Install all used components from Cubase 12 section in the Steinberg Download Assistant, please.

1 Like

Hi Martin,
Thanks for your help! Although I have mixed feelings about the cure… Having to upgrade software for a price… to get rid of what amounts to a nag screen, disquised as an eLicencer error could be construed as a dirty trick.

But, before this turns into a negative rant, let me point out that I was meaning to upgrade anyway, so It’s all good!

So, without going further off topic, Thank you for your help! It did silence the error messages.



Did you install VST Connect Trial in the past by any chance?

Thank you, did it. So far, so good.

Hi Martin,
No… I’ve always had VST connect Pro, and has been registered, and on my eLicenser since 2014. Since I wasn’t ever able to get it to work properly… I sort of just forgot about it. I’m sure the issues I was having was probably pilot error, compounded by my difficulty in finding willing subjects to experiment with.

Anyway… I was already planning to upgrade to give it another shot.

Since there is nothing wrong with my eLicenser, or accounting on MySteinberg… I thought it strange that vstconnect.dll would give an error considering my license is legit. If there was a compatibility issue, then the error should have said that instead of sending me off to find answers!

But again, I’d still be in that boat if it wern’t for your help! Thanks again!

I am getting the same error after I upgraded to Cubase 12 Pro. I noticed that it happens when Cubase loads vstconnect.dll. I took the above suggestion and went to the Steinberg Download Manager and I installed the latest update to VST Connect Performer. I also checked that all Cubase 12 Pro components were installed and updated to the latest releasee 12.0.30. Any suggestions?


VST Connect Performer is not the VST Connect plug-in. Install the mentioned one, please.

How do I install the plug-in? I have installed all Cubase components from the Steinberg Download Manager .

This worked for me: I uninstalled VST Connect Pro and VST Connect Performer from the Windows uninstaller (Control Panel → Programs → Uninstall a program) .