Archeology: Problems trying to convert Cubase songs with SX3

My Mac Pro starting to get old, i decided to reboot in Snow Leopard and use good old SX3 to convert my last residual archives .all to the CPR format. I have an Cubase Pro 8.5 license in the USB eLicenser.

I have two problems: the first is that one on two startup (at least) SX3 crash; i read suggestions about renaming the VST directory, but no solutions. I am considering making a clean installation of Snow Leopard, and a clean installation of SX3 only to solve this problem, but:

Second problem: for around half of the songs in my archive, SX3 crash when it try to import them. So, i am doubtful that reinstalling everything would be a solution of this specific problem.

I wonder if the problem come from the fact that the .all files have been created (many years ago) on Windows; if i install SX3 on a Windows 7/8 virtual machine, accessing my eLicenser thru virtual connection, i should be able to run it ?

Any other suggestion ?


I don’t do mac at all so nothing I can add about that.

I run software for an Axon midi guitar converter that requires Windows XP. I had an old notebook laying around so I put that on there and it works great. Might be nice to put SX3 on there.
If you own a later version can you install earlier versions for free?

It may be interesting for other people to know how i solved the situation: no way to get SX3 to work reliability for converting old Cubase songs on Mac OS Snow Leopard; i installed VMWare on my music machine, got a Windows 8.1 virtual machine, and i installed Cubase SX3 on it. I remapped the USB eLicenser to the virtual machine using the VMWare configuration tools, and i started the maintenance procedure on the eLicencer program in Windows.
At the end, SX3 start, and it is able to convert Cubase songs to the .cpr format; i got a freeze for one of the file, but it look like it can convert most of them.

What is nice is also that i do not depends on Snow Leopard any more to run SX3, that can only run on my old Mac Pro and would not run on any of the other household or future Macs.

You do not need VMWare, VirtualBox should work just fine, but you need a Windows virtual machine; i have a licensed copy of Windows 8.1, but you may be able to solve the problem with the Windows virtual machine that Microsoft allows to load for testing purpose (usually to test web application with different browsers).

Hope this may help,
Maurizio De Cecco