ARIA whitelist issue

I’m having a problem getting ARIA to be recognized by Dorico on my laptop. I’ve whitelisted it and it works fine on my desktop, so I’m confused as to why it’s not working on my laptop. The VST2 Plug-in Path is correctly listed, ARIA Player Multi VST_x64.dll is in the specified path, and the vst2whitelist.txt correctly lists “Aria Player Multi VST_x64”. I can’t add it as a VST Instrument and if I open a file from my desktop that used it, I get “03 - !! ARI … VST x64 !!” listed as a VST Instrument. Playback of correctly assigned instruments not using ARIA works fine so it doesn’t seem to be an issue with any other audio components.

If it matters, this is on Windows 10 on a Razer Blade Stealth laptop, i7-7500U with 16 GB RAM. Any ideas why it won’t whitelist on my laptop? Thanks!

Could you please create a diagnostic report and attach here? With that I can first get an overview and then give more specific advice.

Here 'tis, thanks!
Dorico (379 KB)

The path I specified doesn’t seem to show up in the Vst2xPlugin SearchPaths VSTAudioEngine3.xml file. Should it? Also Vst2Plugin Whitelist VSTAudioEngine3.xml doesn’t seem to have it either.

Screenshot of VST2 Plug-in Path

Screenshot of C:/Program Files/Vstplugins

Screenshot of whitelist

(I deleted the non-multi Aria before the screenshots as I don’t need it, but it still shows up in the logs)

Thanks for the plenty data. Yes, you need to add the path to ARIA to the ‘VST2 Plugin Paths’, otherwise the audio engine won’t “see” it.
And your whitelist is fine, just the name goes in there.
After you edited the plug-in paths, you need to restart Dorico. If ARIA still does not get recognized, please post a new diagnostic report. Thanks

The Aria .dll is already in C/Program Files/Vstplugins folder as shown in the screenshots. Shouldn’t Dorico “see” it there?

Ah, right, sorry, I have overseen this. Then I need to think more about it…will come back…

Thanks! As I was clicking through some of the VSTAudioEngine logs, I noticed that Aria seems to be refused. Any idea why that would happen?

Could you please post a fresh diagnostic report again. I need to check something.
In your screenshot the path to ‘C:\Program Files\Vstplugins’ is shown, but the actual XML file does not contain that path.
Maybe that is the missing link…

Yep, here’s a fresh Diagnostic Report.
Dorico (349 KB)

I just tried removing that path and then re-adding it, but Aria still doesn’t whitelist.

On my Win-laptop here at work I do have ARIA running, but it is installed under C:/Program Files/Common Files/VST2/Garritan
Do you maybe have an older version of ARIA installed at that location (or somewhere else) that might get picked up instead of the wanted one?

The user specified VST2 search paths are only starting points, the scanner will also recurse into every subfolder underneath there.
So please check that there is only one ARIA dll around.

Thanks Ulf. I had just copied my Aria dll to Program Files/Vstplugins. That’s how I have it set up on my desktop and it works fine. I deleted it from there and specified the path you mentioned in my VST Plug-in Paths in Dorico. I confirmed that the Aria dll was in fact in that folder on my system, but I’m still getting the same result. I’ve attached a new Diagnostics folder. Any other ideas?
Dorico (348 KB)

Oh, I think I now know what it is:
In your whitelist you have the name ‘Aria Player Multi VST_x64’, but the actual DLL is named ‘ARIA Player Multi VST_x64’, so the first 4 letters must be all capital. Try it out, I definitely think this will solve it…

It did!!! Thank you for all your time with this. I can’t believe I screwed that up and missed an obvious discrepancy. D’oh! Thanks again!

You’re welcome :slight_smile: