Arpeggiator on a MIDI track? Calling ALL VST Masters & buffs

Hello :slight_smile:
First off, I’ve found threads similar to this already on here but they are of no help to me.

I have an arpeggiator VST called BluARP, I have it installed so that I can load it as an instrument track.

My question is, how exactly do I get this to work with my hardware synthesizer using a MIDI track?

I’ve found people getting help on getting it to work with other VST soft synths but I don’t want to use a soft synth I like hard synths…

I’ll break it down like this,
-F11, add BluARP as VST instrument
-confirm MIDI track
-draw a chord
-add another MIDI track? (this would be the MIDI for the hard synth)
-set the inputs on my hard synth MIDI track to rout to the BluARP MIDI track… & vice versa.

I’m not getting anything to work, so is this even possible to use a hardware synth with a MIDI track to control BluARP?

All help is appreciated! Thanks in advance.

didn’t know that arp. Looks nice. Going to try it later today.
But as i read in your post and on the blue arp site the connection you made is in the opposite way then it should be.

You have an instrument track with blueARP. That is the track where you play the midi notes that trigger the bluearp.
The input can be any keyboard, but you probably are using the external synth as your master keyboard too.
Blue ARP picks these midi notes up and arpeggiates them sending midi out with it’s own midi output. It is that output that should be directed to the external equipment.

Basically you have an instrument track A where the Bluearp is installed as vsti.
You can use any midi input on this track.
Next you have a midi track where you have assigned your external equipment on.
Thing seems to be that you route the midi out of the bluearp to the track where your external synth is located on.

maybe will be posting more details (if still necessary) later tonight, but i’m not at home right now.

kind regards,

Yeah you’re pretty much spot on of how I was trying to get it working, basically this is how I tried routing the two together.

BlueArp via 1st MIDI track (when you load it as an instrument track, it loads as a MIDI track)
IN: All MIDI Inputs

NL2X via 2nd MIDI track on channel 6
IN: 1 - BlueARP - MIDI Out
OUT: Midex8 (3) (this is my MIDI interface that my hardware synth is connected to)

Same experience here.

I can see the MIDI notes played on the external keyboard arriving in the BlueARP VSTi.

The VSTi indicates the notes it claims it’s sending to its MIDI OUT but nothing is actually emerging from the virtual MIDI port.

Exactly, it shows that it’s receiving the MIDI data but no sound.

Same here.

To be fair to it, I wasn’t expecting “sound” directly from BlueARP but I was expecting to see some MIDI appearing on its output. However, nothing emerges despite it tantalisingly showing the notes it should be outputting.

ok, back after some check and yes it works but it is a little odd in the way this is implemented. Also not completely bugfree since on cubase 7.5 both 32 and 64 bit instances froze the entire program. (some loopback)

In cubase 7 it works.

how to:

  1. create an instrument track for bluearp by enabling it in the instrument rack.
  2. in the inspector: midi inputs = all
  3. midi outputs (just below the inputs): BlueARP (midi in)
  4. create a second midi track (i choose another internal instrument but that is just the same)
  5. midi in for this new track= BlueARP midi-out (not midi all)
  6. midi out for this track is where you want the arpegiator to send its data to
  7. to start playback go back to the first track (the track with bluearp) and arm (record button enable)
  8. last step: arm the other track where the midi output is on
  9. keep both tracks armed, but the active track (where you do the input from the keyboard) is the bluearp track so that track should be the active track)

et voila. a working bluearp.
looks nice, but this still needs some bugfixes in my opinion and the routing is not optimal for cubase
(probably made for reaper where you can chain multiple vstis in any order on a single track)

hope you get it up and running this way. here it is working, but it isnt going to stay.
in cubase you have a lot of midi insert fx that do just the same thing and even more complex
but ok: a flexphraser like they use in the halion sonic 2 and halion would be a vast improvement for the midi fx section)

if it still is not working with this info: just let me know, and i try to post some screenshots

kind regards,

Not freezing C7.5 for me but not routing any output (using the 32-bit version).

Obviously something different between C7 and C7.5 with this.

Couldn’t get it to work, I’m pretty sure I had the connections set up like you said… so I took a screenshot to show you detailed information on how I have this set up (or trying to rather). By the way, I really appreciate you helping out physically :slight_smile:

midi 03 should be armed too (record button is red) like was stated in the post :wink:
…and then it works
the rest seems ok

kind regards,

this means that the bluearp for some reason must be armed on midi in and output continously to give output in cubase.
that is the odd routing thing i was referring to. looks like this is not completely correct implemented, at least not for cubase, since on a normal condition a midi fx like this should be normally in the misi insert fx section
(but i am not shure that is open for 3th party devs)

kind regards,

The thing is, is that it is in record enabled mode, it just doesn’t show it as being enabled because the track is not selected, you can see it being in record enabled however in the inspector.

I always have all of my tracks in record enabled mode since I’m always converting MIDI or instrument tracks into audio tracks.

Is there some settings you changed in bluearp?

:slight_smile: we will get it to work on your system. First thing is that I must disagree with your statement. You can perfectly have both record buttons enabled, and if they are not both red, then they are not armed. I do this all the time.

In text: first go to the 2e midi out track and arm. (red button shows up)
then left click on the bluearp track.
the 2e midi out track stays armed (red button stays on)
the arm the blue arp track. (red button is on - now both are armed)

THat is the way it works.
But is see that my post with the different screenshots has been removed…
damn forumrules… :slight_smile:
If it is ok i will pm you tonight and then drop the screenshots it in your mailbox.

kind regards,

Oh, I didn’t realize that because my tracks are minimized to the point where the record enabled button doesn’t show up (just the Mute/Solo and the track name, so that they only show up in the inspector.

So I have both record enabled now and the blue arp is receiving the data from the hard synth during playback and even when playing the keys on the hard synth, but still no sound, I am only getting sound out of the 2nd MIDI track and not the bluearp

ok whe are allmost there. so you get the picture on how the bluearp is connecting and sending its midi data.
the last step is Obvious.

the active track is the bluearp track! Both tracks should be record enabled.

On the second track (where the blue arp output is located on) you have to route the midi data to your external instrument and make a proper connection to your external synth. That is the midi-out (of this second track) selector directly below where you see the blue arp midi output.

select a proper output channel for your external synth and then you have sound routed all thw way round.

If you are not familiar with making connection from a midi track to your external equipment, then figure that out first on another clean (no bluearp) midi track. If you play the keyboard and you hear your external instrument then that track is correctly configured. To allow that track to be played by blue arp, is to switch the midi in of that track from (probably midi all (or you midi input from your keyboard) to the bluearp midi OUT.

that should do it.
if not. let me know. itś just a little step now.

this is a screenshot of how it should be when you want to play the bluearp

kind regards,

I have exactly what you have, (another screen below)
The blue arp is getting audio when I play on the keys but when I draw midi patterns into this track and playback, no audio, when I press keys on my synth, the step sequencer’s leds in bluearp light up.
But no audio yet. It’s very confusing , cause it’s working for you, but I’m starting to think it’s not working cause you’re using an instrument track with a softsynth perhaps?

EDIT: I can’t even seem to get other arpeggiators to work, I’m having the exact same problem.

I am not one to give up :slight_smile: but I think I might have to look at other options, I’ve been looking at the Cream by kirnu
it looks like it has phenomenal capabilities, and it’s affordable.

you see the picture now and where it lacks in the knowledge.
everything is here to get it to work
but the best thing i can advise so that you do not have to download anything
start first with the cubase internal midi fx inserts
they are very advanced and in most cases more advanced then a lot of 3th party plugs
try them out and look how you should connect those to your external synth
if you are able to do this, jump back to the bluearp and then you will have it online in no time
you got a gap in your knowledge of routing somewhere, so that should be handled first
try to do it within the daw in my opinion, as it is capable of and just waiting for you :slight_smile:

kind regards,

I’ve literally tried so many things, I think I have fiddled with just about every input output routing option, it’s working for other people but it won’t work for me this is very strange.

Could it be the channel?

I have the inspector’s channel set to 1 on both tracks and the MIDI channel on my hardware synth is set to 1.

I’ve been stuck on this obstacle for about 5 days now.