Arpeggio Up & Down not showing in score

I seem to not be able to show arpeggio up or down in my scores. I can select a chord and apply arpeggio up or down, and on playback it works, but there is no visual indication. When I click to add these indicators on a chord, all I see is a slight move of the chord, but nothing visual is there. I also checked engraving options to see if there was an option maybe selected to hide these items, but I didn’t find anything. Strangely, I can apply a ‘Non Arpeggio’ and that will be shown on the score…

This sounds like a font problem. What music font are you using in your project?

1 Like

Hey thanks for the tip! Yes it indeed was a font issue - I was using Leipzig. I guess that arpeggiation isn’t a part of the Leipzig set?

It appears that Leipzig is the only font included with Dorico that doesn’t provide visual indicators for the up/down arpeggiation - just tried all of the included fonts…

In theory Dorico should automatically fall back on the characters from Bravura in this case. I’m not sure why it’s not doing that – I’ve made a note to investigate when I get a chance.

Hey Daniel,

I just ran into the same issue with an arpeggio symbol using the Finale Legacy music font. Once I changed my default font back to Bravura it fixed the issue.

Yes there are some fonts that don’t seem to have all of the glyphs. That wouldn’t be a problem if it properly fell back to the Bravura font - Daniel seems to know about it so hopefully it’ll get addressed soon!

I am also experiencing this bug after switching to the Leipzig music font. I don’t think it’s a problem with missing glyphs, but rather with erroneous values of 0.000 for the “repeat offset” parameter of the glyphs in question. As a fix, open the Edit Repeatable Symbols dialog and adjust said parameter for “Arpeggiato up” and “Arpeggiato down.” I found that 0.790 looks about right.

2 Likes

That works for me! Thank you, i hope that this bug will be fixed soon.