Arranger Track Bugs?

I was trying to set something pretty simple up today using the Arranger Track. But it didn’t work.

I wanted to have two Arranger Events, one right after the other. I wanted the first one to drop straight through to the second one, and I wanted the second one (1 bar long) to repeat endlessly. I couldn’t get this to happen.

I had the first one set to RepeatMode=Normal. I have the second one set to RepeatMode=“Repeat Forever”. What happens when I try to play it is that the first Arranger Event repeats forever.

What I want is to start in the second Arranger Event and repeat there until I want the 9-bar break to happen (that’s the first event), after which I want to fall off the end of that and back into the 1-bar repeat forever second event.

I have the following Key Commands set up: 1 to play the first Arranger Event, 2 to play the second. My idea was that I would hit the 1 key whenever I wanted to break to happen, and I would automatically get back to the repeating 1-bar event when the break was finished.

I have attached the Cubase project file to this message. The project folder has lots of large audio files, so I’m hoping the project file by itself will be of use if anyone wants to look at it.

Windows 10, Cubase 10 Pro 10.0.40.
Take (610 KB)


The Arranger Editor does exactly how it is programmed.

Sorry, I didn’t really get, what you want. Could you use the “Break” and “A minor” terms, please?

If I understand it correctly, the chain should be:

  • A Minor > Repeat Forever
  • Break > Normal
  • A Minor > Repeat Forever

Then start with the very first chain A Minor. Once you want to jump to Break, press Next Chain Step (or assigned Key Command). It will go thru once, and then it will jump to A Minor again, which will play forever.

Thanks for the quick response.

Here are two screenshots of the arranger setup I am describing.

I have the 1 key set to “Trigger Arranger Event 1“, and the 2 key set to “Trigger Arranger Event 2“.

To play this, I start by hitting the 2 key. Then I hit the space bar, and A Minor starts to repeat. So far, so good.

When I want to play the Break, I hit the 1 key, and Break starts to play. I want the Break to play just once and then go back to repeating A Minor (to play off the end of Break into A Minor, so to speak), but what it does instead is to continually repeat Break, even though I have the mode of Break set to “Normal“.

I think that either there is a bug in the Arranger Track feature, or there is something fundamental about this feature that I don’t understand yet.


See attached Arranger Editor.

  • A Minor > Repeat Forever
  • Break > Normal
  • A Minor > Repeat Forever

To start the project, hit Spacebar (Start). Once you want to jump to the Break, trigger Next Chain Step (marked by green square; you can assign KeyCommand). That’s it.

Does it work?

I tried what you said and there is still the same problem. For some reason, Break repeats indefinitely.

I am attaching two zipped Cubase projects:

It works correctly here, try Cubase Safe Start to rule out corrupt prefs.

I just tried Cubase Safe Start and the same wrong thing happens with both projects. Break repeats endlessly.

Hm. When I downloaded the project you posted,, and tested it, it worked properly.

Safe Start doesn’t get rid of everything though, have you tried renaming the User Settings folder so Cubase creates it anew?

That’s exactly what I did.

I have a workaround, which is to trigger the second arranger event right after I trigger the first one. That way, the Break event only plays once.

But it would be convenient not to have to do that. And besides, I would like to understand why it doesn’t seem to work the way it’s supposed to.

It looks like things are programmed to repeat endlessly if you use a Key Command to play the arranger part. Notice that the arrows in the Arranger Inspector Chain don’t light up- Cubase isn’t playing the chain, nor using the parameters assigned in it. It’s just playing the triggered segment endlessly until you tell it to move on, and it moves on based on the Jump Mode.

It doesn’t look like a bug, but I agree that it’s not all that intuitive that it would work this way.

It would be nice if they mentioned this behavior in the manual. It wasted a lot of my time figuring this out.

I agree. The manual entry simply lists the controls, but I did not find anything about the actual way it functions.