Arranger track - glitches on pause/start


I am configuring Cubase to use in a live environment, our band is going to play to a click track and have some of the keyboard parts and sound effects running live in Cubase. I’m using the arranger track, which is great, to split a single project in to various sections so I can shuffle round the order, and automate or pause in between songs without having to load new projects.

Anyway, I currently have it set up so that the first three songs on the arranger play one after the other automatically, then it pauses. So I have to hit space-bar for the 4th song to start. However, when I hit the space bar to start, sometimes, not always, the Halion VST will spit out a chord. It is the same chord that I have as the first chord in the arranger, but it’s not due to play for another 8 bars. It’s the same no matter which song I have needing to start manually after an automated pause, doesn’t matter which order or which instrument. If I have an external midi device plugged in it does the same thing.

So, it’s doing;

  1. Play automated song fine
  2. Play next automated song fine
  3. Play next automated song fine
  4. PAUSE - and move to start of next song, ready for a manual start
  5. Hit SPACE BAR to start the song
  6. Chord plays, even though it is 8 bars before there should be any instruments playing!!
  7. Song carries on as normal, starts in the right place, and the first chord (that was played in error when I hit space bar) still plays properly at the proper point

It’s driving me mad - it’s like something is glitching and playing the first event as soon as I push space bar, then it sorts itself out and carries on normally.

I know it’s a very specific issue, but wondering if anybody has any idea at all? There is most definitely no midi or sound data at the point that the noise is being generated.


I’m using cubase (V 6.5) in the same way on stage. I never had any issues like this. I’m always using 2 bars precount (arranger track - to start of the songs) and one bar space to the next song.
Have you taken a look to the midi list editor if there are any controller or hidden note events (mark all midi events and set the cursor to the start point of track 4).

Thanks for the reply. I’ve double checked and there is no midi event - and what leads me to believe it’s more of a glitch is because it doesn’t do it every time. If it was every time I could certainly nail it down and probably find some hidden events. On the three tracks which automatically play each other, they never glitch on me. But if I set them to pause and need a space bar hit to proceed, each of those will also occasionally do the glitch too. Likewise if I automate track 4 to start automatically, it never glitches. It’s only when starting manually.

Am on Cubase Pro 8.0.2 latest version.

It’s the first time I’ve ever set Cubase up with arranger in a live environment so don’t know whether this would have happened in other versions, so it’s a little annoying - am due to start live gigs in a couple of months and am worried I am not going to be able to do it using my current setup!!

I suggest you should render all VST-Instruments and only use audio tracks. I do it like that and as I said I had never any problems on stage. Audio tracks are way more reliable and they have less processor and vst load. Don’t use any plugins on stage!

Thanks - audio files would work, but then I could just take an MP3 player, I’m trying to maintain the feeling of still being somewhat live even when playing the sequenced items. Plus it’s really a mixture of Midi going on - program changes, tempo changes to looper/delay effects, midi data for auto-harmonies, and just SOME of the notes, not all of them, some I am playing live some I am sequencing.

So to be honest, audio files is not really what I’m looking for. I have a very powerful laptop, more than enough to run a couple of VSTs and a few midi tracks, the glitch is definitely not down to processor power :slight_smile:

I do appreciate the response though - but will try and find a fix to the midi glitch!!

If ASIO Guard is on in your Device Setup, try turning it off. That worked for me in a song where the first notes always seemed to get bunched up and spat out all at once.

I don’t mean to render just a stereo file from the main channel. Render just the midi channels (with all automation and effects). This will sound the same! It is just for more reliability in a live situation. Every audience will get bored if you have to fix technical problems on stage.

A mp3 player is not compareable to a cubase system. It has no cue channels, no click, no arranger track with automatic start and stop functions and no single track mixer.

Thanks again for taking the time to reply! Svengali, you’re right, that would work and will definitely be my plan B. However, Ulesto, I think you’ve cracked it - I have disabled ASIO guard and been testing for about 15 minutes and it seems rock solid now - thank you!!