Arrow keys don't transpose midi notes

had the same problem, fixed it for me. thanks!

Five years later and this is happening to me. More evidence that this once-great DAW sucks.
The Steinberg team seem obsessed with adding bells and whistles to Cubase when all we really want is a stable DAW that works.

I tried to do the “workaround” - close Cubase and reopen (although maybe just closing and reopening the project would’ve worked) and predicably Cubase has crashed on me. Again.

FAILURE_BUCKET_ID: ILLEGAL_INSTRUCTION_c000001d_Cubase12.exe!unknown_error_in_process

I finally had a morning to make beats and then this also happened for me as soon as I opened Cubase. Just lost my creative vibe trying to troubleshoot this.

The Go to “Edit > Preferences > Editing” and then enable “Track Selection Follows Event Selection” fixed this but dissapointing that it disabled itself. Please try better Steinberg

Actually that only temporarily fixed it, it is still enabled and having the same issue? I was about to upgrade back might save my $.

Hi again, I also noticed in Cubase 13 that in the editor the normal keycommand for transposing a part with an octave doesn’t work anymore (normally this was Capslock and than arrow up or down).

Does that work in your version?

Hi,

It’s not Capslock. This works with Shift.

Sorry, you are right, it was shift, but that also doesn’t work in my version…

Hi,

Do you have to take some special actions (like minimising a window)? Or it’s not working immediately from an empty project?

Have you tried in Cubase Safe Start Mode or even rename/remove Cubase Preferences folders (all versions), please?

It’s strange… I opened a new project and imported the files from the project where it didn’t work and now it works…

1 Like

I fixed it on mine. Go to Key Commands, the Navigate, and assign up to up and down to down.

Hi, thanks, but although these keys commands are assigned in Cubase 13 it still doesn’t work in an imported midifile. It does work in a new file…

Just had this happen (again, happens often) in Cubase 12: when in Key Editor the up/down arrows all of a sudden change to moving the track focus instead of moving notes up/down in the Key Editor. Totally freaking annoying. This should be horribly embarrassing for the “dev” team as this fundamental bug has been reported for YEARS.

I’ve had this happen to me. Typically it is when I have switched focus to another part of the screen or even another application - possibly unwittingly. For example, if listening to something possibly using another app to compare, using transport buttons and other players.

In Windows programs, deciding where keyboard strokes go is determined by which window has focus, and with Cubase’s multiple windows it is pretty easy to click something which removes focus elsewhere.

Not saying there aren’t problems, but there are numerous ways to accidentally cause the issue.

Ian, no. I’m a developer. It’s a bona fide bug. All you should have to do is click the focus to the Key Editor to get the up/down actions back. Sad thing is the apparently random loss of up/down focus in the Key Editor should be relatively easy to trap for a capable software dude. It’s pretty clear to me they have spent zero time trying to fix it.

Well, I was also a Windows developer (from 3.1) and wrote a C++ book or 2 in my time so I’ve been through the grief of persuading an application to operate focus on multiple custom drawn windows, and as you’ll know it is non-trivial and many apps fluff the problem at some point.:man_shrugging:

I took another poke and for my standard cases, alt-Tab and mouse activation, it does manage to reset focus as long as you don’t do any other activity. However, there are some interactions that will easily lose focus. Say, you accidentally press the space bar and start then if you then click the stop button on the transport you will lose focus even though the highlight remains on the selected note - you will however see that the focus border highlight is lost. Any time I click within the key editor, it highlights the border. Whenever I’ve had the problem, I can see that there is likely to have been some interaction. I don’t generally notice the highlights, but when I have the lost focus problem, as I immediately regain focus by clicking in the window, I’ve not taken a lot of notice of what I did that lost focus.

I guess what I was originally saying is, there are valid reasons why the editor loses focus, so isolating the circumstances where you’ve seen it happen needs to happen. If the developers can’t reproduce the problem, it’s not going to go on the fix list. As a developer, if I got a bug report that says “Randomly loses editor focus” and I poke it and it doesn’t, I might ask around the office to see if anyone else has noticed otherwise it goes in the “request more info” pile.

Good info Ian, thanks. Because this has been a known problem for years it’s in the “extremely annoying” category for me and many others based on posts.

Someone in the " [Up and down cursor not editing my midi notes]" thread suggested closing the Channel Settings dialog to clear the error state. I had this bug happen twice today during an all-day session. The first time I closed Cubase and restarted to clear the error. The 2nd time I closed the Channel Settings dialog (which I always have open) and then re-opened it. Viola. That also cleared the error state. Maybe this always work. Time will tell…

I now have the latest update but it still doesn’t work… Do you get the same results?

Start a fresh topic for this please.