Arrow keys don't transpose midi notes

Hi I am having a issue where i can’t transpose midi notes after a few hours or so of using Cubase. What happens instead is up and down keys highlight which track the focus is on instead of transposing the note i have highlighted in the midi editor window. Left and right work as per normal.

I have to restart Cubase to resume normal operation.

Thanks!

Hi,

It sounds like there is not focus in the Key Editor. Can you see the white focus frame?

I was having this issue as well with the editer in focus.

Yes, the Key editor was in focus. This issue started happening with Cubase 10. I need to do a restart of Cubase to get it working again.

Do you have some channel configuation opened?

it happened to me sometimes that the arrow keys changed track selection and not midi notes if the channel config was opened.

Nope nothing else opened. Even full screen the key editor it still happens. Nothing else is highlighted. Cubase 9.5 before this was working as expected. Seems it’s a new bug introduced with C10. Also seems like i’m not the only one experiencing similar behavior, so it’s not an isolated case.

Hi,

Is there any clear repro? Are there any clear steps how you call always reproduce this, please?

Yes, after some troubleshooting i am able to replicate the issue by minimizing the Cubase window by clicking the top right underscore icon, then restoring the window again. I need to restart the project to bring the up and down arrow keys back to normal as left to right still function as intended.

I’m having the same problem. Don’t know how to reproduce it, but it happens occasionally. I’m using the MediaBay alot and it’s a pain in the butt when I try to preview different sounds by scrolling though them using the up and down arrow keys but instead I just switch between channels in the project window. Restart is my only fix so far.

This is on Cubase 9 btw.

I have the same issue. I have another bug with my 4k display that forces me to minimize Cubase with “minimize all” and maximize it again. After I’ve done that, the arrow keys don’t work any more most of the time, showing the behavior described in this thread. This is a huge issue for me - it’s there all the time because of the other bug!

Please Steinberg fix this!

Same issue here, very annoying. And as usual nobody from Steinberg looks here. I try make a formal ticket in their support.

Hi,

This thread was highjacked by another topic (minimise the window). Do you refer to the original report – “Arrow keys don’t transpose midi notes”, please?

If yes, do you have a clear step-by-step repro, please? Could you attach your preferences folder (ZIPed), please?

This happens to me constantly. I don’t know why it happens. I’ll be working in a session and the left and right keys work fine. But up and down will only go up and down on tracks. Even if I have the note highlighted and I have a full screen piano roll editor, I can never figure out how to regain control of moving notes up and down. Aside from the constant crashes of Cubase 10 and the lack of a right-click MIDI menu, this is my new least favorite feature.

Hi,

Make sure the Preferences > Editing > Use Up/Down Navigation Commands for Selecting Tracks only is not enabled.

+1
The same bug appears occasionally.
Minimize|maximize window seems to temporarily solves this

Preferences > Editing > Use Up/Down Navigation Commands for Selecting Tracks only is not enabled !

Same bug here. And also +1 on the right click midi thing. What happened to that?!

+1 same bug here

Hi,

Sorry, I still can’t reproduce it here. What could be the link among your systems, I’m missing?

Hi,

I was searching for something else and this thread popped up. I’ve noticed this. I can’t say I have the answer, but I notice that Cubase will sometimes set notes to SATB “voices” and when that happens, the arrow keys don’t seem to work.

I’ve not nailed down what exactly is happening here, but the next time this happens, check the info line and see if notes are set a particular voice.

I notice when I drag chords from Chord Track to a MIDI track that Cubase is now assigning voices to the notes in the chord. I don’t want this to happen and it seems to have appeared in version 9.5 or so. I’m not sure about this and have to check more carefully to see what’s going on.

I tend to just work around things like that that pop up. In the case of the arrow keys not working, sometimes hitting F5 sort of resets things (windows machine) and the arrow keys work. Selecting all the notes on a track and removing voice assignments sometimes clear this up, but again, I’m not totally clear on this.

Anyway, yes, I’ve seen this. But, no, I can’t duplicate it with any set steps. I think there’s an issue with the Chord Track, Live Transform, Voices, etc. but I’m not sure what exactly it is.

+1
I have the same issue quite often. When I try to transpose notes in the key editor, suddenly it doesn’t work and the previous/next track is selected instead in the track edit window (which I have open on a separate screen all the time). The only workaround is to close the track edit window temporarily, and after a while it will work again. Please fix this, it’s really annoying.