Arturia Keylab Essential 61 with Cubase VST & Track Quick Controls

Hi all,

I’m using Cubase 10 Pro with ‘Arturia Keylab Essential 61’ midi controller keyboard (I’ll refer to this as ArtKL61 hereon)
The ArtKL61 has eight midi knobs and 8 sliders.

I am trying to set up the 8 knobs and 8 sliders to be ‘VST Quick Controls’ and ‘Track Quick Controls’ in Cubase 10.

I’ve watched tutorials on youtube on how to do this with generic midi controllers in cubase and my ArtKL61 is not behaving as the controllers do in these tutorials.

Tryign to get The knobs to act as ‘VST quick controls’
The knobs will change the ‘address’ in the ‘VST quick controls’ section (in Studio Setup) - however the ‘Midi Input’ has to be set to ‘all midi inputs’ . If ‘ArtKL61’ is selected then the knobs will not make any changes at all.
Once the addresses are defined - the knobs will then control the 8 VST instrument knobs (as I can see in the VST instruments window) - however the control is not smooth - only two positions on the virtual knobs can be switched between - which is useless!

The ArtKL61 knobs will not change the addresses in the list for ‘track quick controls’.

The ArtKL61 sliders will not change the addresses in the list for both ‘VST TRack Controls’ and ‘Track quick controls’.

Please HELP!!

It may be a fault with the controller - but I feel there’s probably some fundamental setting I’m missing here. Highly frustrating - any help - you will be my GOD!

Ross

Hi,

As far as I know, you can use Arturia Keylab Essential 61 in several modes. What Mode do you use, please?

Hi Martin,

Since my first post I have been going back and forth with Artutia customer service - but so far they haven’t been that helpful. Maybe they’re assuming some inate knowledge that i don’t have but I’m still no closer to the goal - which anyone I know or anyone on youtube seems to be able to achieve instantly!

The mode of the keyboard ? I’m not sure. Here’s where I am with troubleshooting…

  • Arturia first told me to factory reset the controller
  • Arturia told me to set the ‘DAW mode’ in the ‘Arturia Midi Control Centre’ to ‘HUI’
  • They then told me to add a ‘Mackie HUI’ device in Cubase / Studio / Studio Setup window and set the ‘midi input’ to ‘MIDIN2 (Arturia Keylab Essential)’ and the ‘midi output’ to ‘MIDOUT2 (Arturia Keylab Essential)’
  • They then told me to untick ‘MIDIIN"’ in the ‘midi port setup’ section of the ‘Studio Setup’
  • They attached two template files to their email to me , the file names of which were called ‘KLE-TRK-QC-Template.keylabessential’ & ‘KLE-VST-QC-Template.keylabessential’ (i’m guessing one is for Track Quick Controls and one is for VST Quick Controls in Cubase)
  • They asked me to import these files into the templates section of the Arturia MIDI control centre
  • They then asked me to ‘Import the templates into the MIDI Control Center and “STORE” one on the USER MAP 1 and the other one in USER MAP 2’
    I took this to mean 'select the ‘KLE-TRK-QC…’ file in the ‘local template’ window / then select ‘USER 1’ in the ‘Device Settings’ window / and then click ‘Store To’ (and then follow the same process for the next file but with User 2)
    However there’s no way of knowing if the files are assigned to the user numbers once ‘Store To’ is clicked

they then said - “that’s it”

well it’s not it is it? - because nothing is mapped yet!!

  • I then I tried to do the ‘learn’ process in ‘track quick controls’ and ‘VST quick controls’ - ticking learn and then fiddling the appropriate knobs or faders on the controller
  • I understand each knob and fader has it’s own ‘MIDI address’ this address should be assigned to the ‘track quick controls’ and ‘VST quick controls’ when fiddled, with learn ticked.
  • However - the address only changes to ‘144’ for any knob or fader fiddling with.
    …and the they’re just not controlling anything
    I fail to see where the ‘User 1’ and ‘User 2’ of ‘Arturia Device Memories’ comes in when navigating the Cubase interface.

Any tips would be much appreciated, if you have them at this point.

It’s the most un-user friendly / poor UX experience of my life!

Ross

Hi,

Today, I have KeyLab 61 Essential on my desk.

If you switch it to the DAW mode (press Map Select button and then press Pad 2: DAW), the Keylab acts as Mackie Control Device. For this, you have to add Mackie Control device in Cubase > Studio > Studio Setup (click the + button there). As an Input choose Arturia KeyLab Essential 61 DAW In. As an Output, again …DAW Out.

But, if you would use KeyLab in this mode, you can’t reach the Quick Controls. In this mode, you can use the sliders to control Cubase MixConsole faders, and the encoders to control the Pan.

If you want to use KeyLab for the Quick Controls, switch to other mode. For example User 1 (Map Select > Pad 3). Now the KeyLan sends common MIDI CCs to the MIDI out (not DAW). But the Transport section still sends the data t the DAW In, so you can keep the Mackie Control.

Now, when you are in the User 1 Mode, open Track Quick Controls in Studio > Studio Setup. Set Arturia KeyLab Essential 61 MIDI In as input. Enable Learn in the Track Quick Controls and move the encoder 1. Then select the Quick Control 2 and move encoder 2 on the KeyLab. Continue until Quick Control 8 and encoder 8. Then do the same with the VST Quick Controls, but move the KeyLab’s sliders instead of the encoders.

Now the hardware > Quick Control mapping is done and you can control the Quick Controls from your KeyLab.

Hi there Martin - thanks for this

I’m following the instructions as you said - however I’m using a Windows machine - I have a feeling you’re using a MAC?

I’m afraid its still not working
(I take it when you say ‘encoder’ you mean ‘knob’?)

MY SETTINGS

  • I have ‘User 1’ selected on the actual physical keyboard
  • Keyboard is plugged in via USB
  • I have Mackie HUI setup in cubase studio setup with MIDIIN and MIDIOUT selected (the Windows version as I understand it) - see pics below
  • I have HUI setup in the DAW mode of midi control centre (as opposed to Mackie Control)
  • In ‘midi port setup’ I have deselected MIDIIN2 in the ‘All midi’ column (goodness know why - that’s what Arturia said to do)

For clarity - Ref this Dropbox link below for screenshots of all those settings I’m referring to

With these settings…

  • nothing happens in TQC and VSTQC when I fiddle with the knobs and faders (with learn ticked). i.e. the numbers in the address column are not changing. I understand this means it’s not working - am I right?
  • The keylab is sending regular pulses of midi signals into cubase (see video here - https://www.dropbox.com/s/9qtj3gyszsa2mea/2020-12-11%2017.38.05.mov?dl=0)
    This shouldn’t be happening right? I feel this is a symptom of the setup not being correct.

The reason I want to control the TQC and VSTQC is simply so i can control parameters of plugins / VST instruments that I load into cubase (without having to use the mouse). Am I going about it the right away?

Thanks SO MUCH for trying to help so far.

Ross

Hi,

Yes, you are right, I’m on Mac.

What is definitely not correct, to use the very same MIDI Port as Mackie HUI and as Quick Controls Input. Unfortunately, I don’t really know, how are the MIDI Ports named on Windows. But if MIDI IN 2 is in use for Mackie HUI, use the Arturia KeyLab Essential MIDI In for the Quick Controls, please.

If this settings wouldn’t work (but my guess, this settings is correct), just try to switch the MIDI Ports:

  • MIDI IN 2 for for Quick Controls.
  • Arturia KeyLab Essential MIDI In for Mackie HUI

From the MIDI Port Setup > In ‘All MID In’ column, disable the MIDI port, which is in use for Mackie then, please.

2 Likes

OMG it worked!
The only thing i changes was - In the TQC and VSTQC midi ins and outs I selected just ‘Arturia Keylab Essential’ for the midi input and output and clicked ‘learn’ and the addresses changed as expected.
I’ve tested this now with the actual quick controls etcs and they work when I select ‘User 1’
I’m not sure if the templates Arturia gave me contributes to them working but they do!

The ony thing I’m not sure about is the weird midi pulsing occuring with this setup

Do you know what this is - or if it should be happening?

Video link here showing the pulsing

Hi,

I’m glad it’s working now.

The pulsing comes from Arturia. Mackie HUI protocol is designed so that it’s sending pulses to inform, the device is still connected and alive. If you would deactivate this MIDI port from the All MIDI Inputs, you wouldn’t see these pulses anymore. Or if you would use Mackie Control instead of Mackie HUI.