Arturia KeyLab Essential 88 -- fixed

Hi there, I have Cubase 12 Pro and Arturia KeyLab Essential 88 MIDI Controller. Unfortunately, it does not get recognized in MIDI Remote window. Do I need to set up my MIDI Controller in MCU or HUI protocol? does it even matter? any ideas?

thank you in advance

Hi @dkalna, sorry we made a mistake in the script. Please download this exported and (hopefully) fixed script:
Arturia_KeyLab_Essential_88.midiremote (5.8 KB)

And then use the “Import Script” function in the MIDI Remote Manager.

hi Jochen, that’s great! now it works. thank you very much!


I can set up all my knobs, faders, and pads using MIDI Remote Control but the TRANSPORT buttons don’t register when I press them. They DO work in my previous DAW (Ableton)

solved now and works fine

Is there a script yet for the Arturia KeyLab 88 mkII?


Arturia has a template for cubase already?

1 Like

Eagering awaiting script for mine as well. Lol such a great board. Will keep ears and eyes open about this

Downloaded the new script and I have the same problem - no transport although it appears to be mapped properly.

Oh i’m also waiting for the script for MKII - without integration into cubase 12 the board is of little use


I offered many times here on the forum already, I would adapt the KeyLab Essential script to the mkII. But I don’t own the device, so I would need some cooperation. I would need to get the specification. What MIDI Messages do the controls send?