Arturia Keylab sliders mapped to Cubase but work intermittently

I have an Arturia Keylab 61 connected to my Cubase and most of the MIDI mappings (default ones) work fine - Transport controls, knobs to pan, etc, but the sliders are really flaky. They take a while to respond, and when they do, they don’t match the actual slider movement; they just randomly flick up an down then stop, then move again, and so on, making them totally unusable. I’ve tried using the Generic Remote (with Learn activated) but there is no response to any slider or knob movement. I’ve played around with this so much that I reckon I’ve probably now made some strange fundamental change that I don’t know about, or how to undo it. Is there a way of doing a total reset?

Could you ost a screenshot of the Generic Remote definition that you created, the two panels showing how the sliders have been defined ?

A properly set GR definition will surely help and be more easy to achieve, before eventually use a MIDI Remote one…

Thanks for your response.

See screenshots below. Initially I created a Generic Remote, and when it didn’t work I tried to delete it, and then mucked about with it so much that I deleted loads of lines from it. I then added a new GR (default name – Generic Remote 2) which was clean, but I suspect it may be conflicting with the dodgy first one.

This is the one I’ve messed up completely…

…and this is the second one; unadulterated. (I created a new project, so that I would have a clean start, and just added one audio track).


How can I get rid of the first one, or if I can’t do that, reset it to default? Highlighting Generic Remote and clicking the “-“ at the top of the Studio Setup page just hides it, and importing generic.xml does nothing. Reset does nothing too, so I’m not sure what that button is supposed to do.



Here’s the second image.

Normally, using the - button should do the trick : here, it removes completely the Generic Remote definition selected and I have to recreate one and Import its definition to have it functional again. Another way to get the same result is to set both MIDI input and MIDI output to Not connected.

This said, what do you want to do with the faders ? Because I see, in the Channel/Category column of your Generic Remote 2 lower panel some strange values : you shouldn’t have digits in it or a simple ‘a’. Worth a check, I think. Another thing I would do is to set the Flags in the upper panel as R, , ,P (read + Pick-up) to have a kind of ‘soft takeover’ faders .

In example, to use a Generic Remote definitions for my keyboard controller sliders as general level controllers, I have this :

EDIT : whether you choose to use a MIDI remote script or a Generic Remote Definition, be sure that the one not used is either deactivated (MIDI Remote script) or Not connected (Generic Remote definition), to avoid conflicts.

I don’t really understand what’s happening with this. Yes, when I click the “-“ button, the Generic Remote disappears, but when I click the “+” to add a new one it defaults to what you saw in my first attachment. I just require the faders to control the volume on each individual channel. As I say, when I move each physical fader on my MIDI keyboard the digital ones on the screen move, but randomly. e.g. I slide the fader up and down and the relevant channel automatically selects and the digital fader moves, but not matching the physical one. It’ll, say, go up a bit of the way, then stop, even though I’m still using the fader, then it’ll jump to the top, and then nothing at all. So, it’s completely random and not mimicking the physical fader. When I try to use Learn, it doesn’t work at all. Nothing happens to the values when I move any given fader. Or sometimes the value goes to 144 and that’s it. I’ve seen videos on YouTube and can see that whichever knob or slider is used when the Learn box is selected, a number, between 1 and 144 is automatically generated, and a different number for each line. Whatever I do, they all come up as 144!

With regard to my second attachment; I created a new project, with just one audio track (which I named “a”; just a random name so that it showed a channel name). What you see in the attachment is simply the default of how the Generic Remote 2 screen appeared when I created it. The “a” was there by default because that’s the name I gave the audio track. I hadn’t edited it all.

Very puzzling!

Concerning the Learn option, disable it if needed. Here, it works without issue, using a MIDI DIN cable to connect my VMK-188+ to my DAW.
Beside this, how many channels do you have ? I just tested the Generic Remote definition to control the volume of some different channels I have in my all purpose project template :

It also works as expected, Cubase channel faders following perfectly the moves of the VMK ones.
So, I suspect that something is wrong, either in some Keylab settings or in the connection between it and your DAW. How is the Keylab connected to your DAW, USB or MIDI DIN ?

I would suggest to check the MIDI data received in Cubase, using the bundled MIDI Monitor plug-in as a MIDI insert on an instrument or MIDI track and see if the data values are corresponding to the ones defined in your GR definition.

If everything still go wrong, maybe it’s time to mark your GR definition as Not connected and use the MIDI Remote feature instead, even if I doubt that it will help, as something fishy seems to occur in the way Cubase receives the Keylab data…

To answer your questions:-

I have 16 MIDI channels

I use a standard USB MIDI cable

I’ve set the MIDI as Not Connected on the dodgy Generic Remote. I have three Generic Remotes now as it seems that once one has been added it can only be removed from the display (with “-“, but not actually deleted.

I’ll see if I can find that MIDI Monitor plug-in you mention.

The whole thing is so flaky. I just added yet another project – see below. This time the faders work fine but the knobs for panning (which worked perfectly before) now do odd things! E.g. one of them pans correctly but each time I pan right it not only pans right, but also mutes all the channels! Panning left fades left and also unmutes them. WTF?

For info, the keyboard does everything (all sliders, knobs, buttons) perfectly when it’s simply connected to Arturia’s Analog Lab V, so the issue must exist within Cubase, and is not due to the keyboard or it’s MIDI connection being faulty.

I’m rapidly coming to the conclusion that I’ll have to use the Keylab 61 for transport controls only (since they work fine, and the keys, of course) and just not try to use the sliders and knobs. Which is a shame. There’s something fundamentally random about the MIDI control by default, because in the last two projects I’ve not even tried to set any customs controls and I still get this totally random flakiness.

I’ve discovered that I can solve the weird slider issues by clicking Reset at the bottom of the MIDI drop-down menu. However the strange pan control/random channel muting issue remains the same, as does the problem with Generic Remote not learning anything.

Thanks for you assistance. However, I’ve just upgraded to Cubase 12 and the process for mapping is much simpler and intuitive and 100% effective (so far!) utilising a visual display of the keyboard to select what needs to be mapped. Worth the ridiculously good value £15 upgrade.