Arturia Spark2 s a Plugin in Cubase 11 Pro - Has anyone ever got this to work?

Windows 10
Cubase Pro 11
Minilab Mk II


I have read the FAQ’s and various online tutorials for both Cubase 11 Pro and Arturia Spark2 and nothing has helped.

I have asked on the Arturia forum but the couple of users who answered do not use Cubase and were unable to assist me beyond saying I need to ask a Cubase User so here I am on the chance that someone in here may use Spark2 in Cubase.

I have no idea if this as a Cubase issue or a Spark2 one.

I want to use Spark 2 as a plugin and I want Spark to play what ever I compose in a Midi track in cubase (in the same way any other VSTi does and then I want to be able to ether Render the audio in place or export it as a Audio track in cubase.

I open Spark 2 as a Track Instrument and it is assigned by cubase. I can hear sounds from Spark if I click on any pad in the Spark2 User Interface with my mouse or use the keys on my Minilab keyboard.

If I open the Cubase MIDI Editor (Piano roll) and click on any of the the keys for for Spark2 (C3 - D#4) the sounds play but if I enter a MIDI note, for example a simple 4 beat bar with one kick on each bar, Spark will not play them.

When you first load an instance of Spark2 it gives the following error message:

“Spark Controller connection failed
It then say to turn off some MIDI connections in my DAW MIDI settings. Please refer to the user manual.”

In the Manual it says:
Go to your sequencer’s MIDI settings and turn off ‘Spark Private In’ and ‘Spark Private Out’.
Without this configuration:

  • Spark controller will not connect to Spark on Windows.
  • Spark controller will not behave correctly on OS X

So I go to my Cubase 11 Pro Studio Tab > Studio > Studio Setup > MIDI Port Setup and there is no Spark Private In’ and 'Spark Private Out.
What I see is:
Windows MIDI | In | Steinberg UR22C-1 Active
Windows MIDI | In | Arturia MiniLab mkII Active
Windows MIDI | Out | Steinberg UR22C-1 InaActive
Windows MIDI | Out | Arturia MiniLab mkII Inactive
Windows MIDI | Out | Microsoft GS Wavetable Synth Inactive

I go to my Cubase 11 Pro Studio Tab > Studio > More Options > MIDI Device Manager and again no Spark Private In’ and 'Spark Private Out.

I’ve wasted two days trying to get this to work and my client is getting a little annoyed (can not blame them) as so close to Christmas time is the biggest issue.
I absolutely need to sort this issue out.

I would be very gratful for any help.

Many thanks.


Spark 2.4 works as expected here (C11 Pro on Win 10), so it’s neither a Cubase or Spark issue.

Since you can play Spark with your Minilab and by the keys in the editor the setup seems to be fine (forget about the missing Spark Private In and Out, those are only relevant if you use the Spark controller).

Is your MIDI part maybe muted by accident? You wouldn’t see that in the editor…