ASIO Driver for UR22 Not Recognized

Hello,
Can someone please tell me how I can resolve a problem with Cubase not finding an audio driver? I used the program for a few months with no issues, but one day was no longer able to hear any audio because Cubase will not recognize the audio driver. I uninstalled and reinstalled Cubase (with the associated audio driver) hoping to fix the issue, but the same thing is occurring. Specifically, when loading Cubase AI7 (7.0.80) with my Steinberg UR22 device, I receive a pop-up window that reads: “ASIO Driver Setup, Select the desired ASIO driver.” The only available option is “Yamaha Steinberg USB ASIO, Steinberg UR22.” Therefore I select it and click the OK button. Next, another pop-up window appears that reads: “Driver could not be selected”, which then forces you to click an OK button. After opening a project, outputs are unmapped. Even when opening the device setup, the VST Audio System section displays that there are no available drivers. Please assist me at your earliest convenience. Thanks

Hi and welcome,

I would recommend you to download and install the latest UR22 driver. If it doesn’t help, try to connect the UR22 to the different USB port of your computer, please.

I use Ur22mkII together with Cubase. Usually everything works. Today, suddenly Cubase would not detect the Ur22 driver no matter what I did. I reinstalled the driver several times, I connected the Ur22 to another USB port on my computer, and I restarted the computer again and again. Nothing helped.

At one point I went to Steinberg.net, downloaded a “firmware update” file for the Ur22 and ran the update. Now everything works again. I can´t 100 % guarantee that it was the firmware update which solved the problem. But apparently it was.

Hello everyone and especially MVVR,

I recently stumbled upon the same problem on my iMac using the UR22mkII, after not using it for a few months. I realized that macOS would detect and use it as input/output, e.g. both iTunes and Bias FX got it, but NOT Cubase. My system setup is a iMac 21,5" late '14 with macOS 10.13.3, Cubase AI 9.5.20 and the latest Yamaha USB driver.
After searching and fiddling around I tried to solve it with reinstalling USB driver (first deinstall the existing, restart, than install the same driver once again) for macOS which apparently worked - until today. Before getting nuts with that stupid problem I searched again through the Cubase settings and came across the “VST audio system” (Go to “Studio” -> “Studio settings”). When I changed the ASIO driver from “integrated audio device” to the surprisingly (or not) detected UR22mkII, Cubase got it.

Long story, short: in my humble opinion, it is not firmware but the ASIO driver settings in Cubase you first have to search for when facing such a problem again. Please somebody with high experience confirm that, I am not a power user. If correct I could imagine that the root cause is not Cubase but macOS with its ASIO drivers. This might be caused due to system update as I first started using Cubase with macOS 10.13.2.

Regards,
Matthaeus

Hi,

You are right. You have to select the ASIO driver first in the VST Audio System.

Hi. Same problem here. Cubase AI 11 not detecting drivers. This has been a problem for 2 weeks now but until today I’ve been able to open in safe mode and manually select ‘Steinberg U222 MKII’ as input but now that option is not being offered to me. I go to VST System Link and the interface is not there. It’s plugged in. I have changed nothing in my setup whatsoever since this was working. I cannot uninstall and reinstall Cubase. I spent 6 days trying to get it set up last time I did that.