ASIO Driver/Headphones/Audio Interface

I’ll start off by saying I’ve scrolled through a handful of other threads about audio interfaces. I have tried a bunch of things and for some reason I am still having trouble with getting the Cubase audio to route through the audio interface, or headphones, output.

I’ll start with the specs:

Laptop- ASUS ROG M16 (2023) w/ Windows 11
Version-Cubase 12 Pro
Audio Interface (kind of)- SP404 MK2
Headphones (any, but currently) Bose QC 45 (using them wired)

The Problem: The SP404 MK2 is a sampler but it has a built-in audio interface. I have used it with other laptops/desktops (Mac and PC) and with Ableton Live 11 (however I am currently trying to make the switch to Cubase). I can use the SP404 as an audio interface with the laptop with no problems. I plug it in (USB-C to USB-C) and it works for the computer normally. I can plug in any headphones to the SP404 headphone jack and I can then use the SP404 Master Vol knob to control volume like it should, acting as an audio interface. Disclaimer: This is a travel setup, and only the first time I’ve tried the SP404 with Cubase. I have a Focusrite at home and a desktop.

So, Cubase does not recognize the SP404 as an audio interface. I would think it was something to do with the SP404, but when I’m going through the settings on Cubase I can only get audio output (of any kind, normally through built-in laptop speakers) on the Generic Low Latency ASIO Driver. I have an option to choose Realtek ASIO, however I can not get any audio output at all when I choose Realtek. The Windows audio panel in the lower right of the screen recognizes headphones and the SP404. I can use them both normally (plug n play) on any program, game, website, etc. except Cubase.

Even without the SP404, I cannot get the Cubase audio to route through the headphone jack as it normally should. I will plug in headphones and either they won’t work but audio still comes from laptop speakers, or after changing the settings/drivers a bit audio doesn’t play at all.

So, basically, what do I need to do to get audio to play through either an audio interface which is not recognized or, more simply, just through the headphone jack at all? Again, I have changed the driver between the Generic Low Latency ASIO (the only one that works) and Realtek ASIO (doesn’t work…those are the only two options available), and I’ve changed output to Headphones (which are sometimes recognized by Cubase) but then all audio stops playing.

ASIO drivers are required for Cubase. If Roland does not make an ASIO driver, your best bet is ASIO4All

Appreciate the help. I’ll try ASIO4ALL for the SP404.

Is there something I’m missing with regards to just using headphones from the dedicated headphone jack on the laptop?

Edit: ASIO4ALL allows me to use headphones, but I have to go back to Generic Low Latency Driver for laptop built-in speakers. This isn’t a huge problem, but if anyone knows how to avoid changing drivers every time, please let me know.

ASIO4all can address all audio connections available on the system.

Cubase can always address only 1 audio device at a time. In your case that would be either the SP404 MK2 through USB or the headphones through your computer’s built-in soundchip.
So you’d need to connect your headphones to a headphone plug on the SP404 MK2.

Furthermore, as was pointed out already, Cubase does not use Windows’ audio system at all but rather uses its own, independent audio system called ASIO. However, I could not find an ASIO driver for your device. This is where ASIO4ALL should come into play - it software-connects ASIO from Cubase to the Windows audio driver of the selected device.

If it is not working, feel free to post a screenshot of the ASIO4ALL control panel. It should look something like this:

I’ve been everywhere on this, and am slowly becoming less of a noob amateur hobbyist, but wow are there are a few factors or what?! Mileage will vary!

Message-in-a-bottle #9, re ASIO4ALL (A4A) audio on windows - I have been looking at all the options to do “loopback” , first trying to create an “aggregate playback device” like on Mac, using A4A (windows 11 pro).

I’m first trying to see if A4A can be used to target the actual device (device-mapping)
issue 1 audio goes to device1 (headphone) even when configured explicitly

Will check:

  • disabling device1 (speakers) in windows, to force output to headphones
    (little value)
  • disable exclusive audio access to see if that’s an issue
  • mapping two distinct devices
    eg add another audio interface, although that’s arguably introducing more complexity!
  • further config in app’s audio-settings to try to target device
    (straw-clutching here)

This was just a step 1 ^ whilst troubleshooting similar & other issue when trying to use ASIO4ALL to output to Headphones and Speakers

A4A interface suggests it should be possible
(View after loading app that’s configured to use A4A)
[unable to add other images as I’m new )

app-log reports same channels as seen in A4A
- ASIO : ASIO4ALL v2 (device #6 with 2 ins 4 outs)

But (like issue 1) when using the app the only audio heard goes to headphones.

Hope that makes sense! And some ideas here, or info on why it can’t be done (if it isn’t just me) and other options.

Thanks in advance for any contributions!

The app config seen and desired - note two playback devices (4 outs)

Was gonna add links to config instructions I’m following, but computer says no!
Interesting policy! Thanks again!

Further testing and spamming cyberspace, and it’s working!
Only changes I made were to test banana (which isn’t being used so shouldn’t be a factor) and force WDM (but it continued to work after disabling)

This is a game-changer! Further testing before any useful how-to or next device config - virtual input, where each channel is an input (hw - guitar / vox) or an app