ASIO Generic driver window always appears when loading file

Just updated from SLP7 to SLP9. Wow. It’s so much -snappier-. Frankly, I hadn’t used it much because various tasks took so long. Well done!

However… every time I load a new file it opens the ASIO Generic Low Latency window–despite the fact that my RME Hammerfall drivers -are- selected in Preferences.

Any way to fix that?



Glad you enjoy it !
SL9 indeed scan ASIO devices at launch, this behavior will be improved in a future update.
However I couldn’t repro the issue you mention : there’s no such thing as the ASIO Generic Low Latency window showing on the couple computers I tested. Could you screenshot that ?

If you’re never using that ASIO Generic Low Latency driver, then the easiest workaround would be to simply uninstall that driver - it can be uninstalled like all regular applications.

Here is the startup on my machine. Win 10/64 old “Haswell” i7. RME 9652 card fwiw.

It’s been doing this since I got SLP6 IIRC.

Again, in Preferences, the correct Hammerfall drivers are selected. It’s just a bit off-putting because it makes me -think- the thing is under-performing. I mentioned the sluggish performance of SLP7–which I chalked up (perhaps) to SLP using the wrong drivers?

And again, the performance in SLP9 is dramatically better (thanks!) But regardless, I hope this dialogue will go away at some point soon. :slight_smile:

I’ve found that selecting the WASAPI driver in Preferences works quite well in SpectraLayers.
I also have an RME ASIO device, and yes, one would imagine it would be preferable to use ASIO, but as there’s no latency issue when using an audio editor, and WASAPI works fine, I leave it like that.

Another thing you could try is just uninstall the ASIO Generic Low Latency driver (assuming nothing else needs that driver, which gets installed by default with almost every Steinberg product these days). If the only other ASIO driver installed is the RME one, then that will “scan” quicker.

I have ran into issues using WASAPI. Sometimes audio wont play (when you press play nothing happens), it usually happens when I’m running multiple programs that use other audio drivers (for example OBS using Asio). A quick fix I found for it is to switch back and forth between Asio and Wasapi and it usually ends up playing again.

On that note/speaking of asio. Steinberg (if you’re listening) your asio drivers are really bad (and I mean really really bad). I would highly suggest and recommend for you(Steinberg) to do extensive testing of your asio drivers outside of DAWS. I have come across numerous issues using video editors and screen capture apps on your asio drivers. I would recommend for Steinberg to test asio with programs like DaVinci Resolve because I personally have run into so many issues using asio with video editors, and for me to report bugs and issues of asio drivers to Steinberg would be a full-time job. Also the beta asio plugin for OBS also has numerous issues and after using it I’m wondering how are other people using asio drivers and working with it if I’m having so many issues?