ASIO Guard and Vienna Ensemble

When I have AG enabled, I get a 1 second (ish) pause in audio each time I select a different track in the project window. This only affects changes going to, or from, a VE instrument. If I turn AG off, there is no glitch. Is anyone else experiencing this? As it stands, AG has no benefit if I use VE, which I do extensively.

I think this has been brought up and has been activity discussed on the VSL forum. Supposedly VSL is in contact with Steinberg to see what if anything is going on.

Thanks for the heads up.

https://www.vsl.co.at/community/posts/t38487-VE-Pro-audio-muting-when-switching-tracks-in-Cubase-Pro-8#post233015
here’s the topic

Only works for me with ASIO Guard set to minimum.

It seems they have a thing against VSL because the articulation mapping does not work with the large number of articulations in typical VSL matrixes. I think that is why VSL did not implement the VSTi feature which allows you to get the map from the VSTi automatically. I wish they would. I think these two companies hate each other. I remember before the mapping feature was released VSL was excited about it but then not so much when it came out.

I am using ASIO Guard in the default position with VSL after tweaking the “Visual Effects” performance options in Windows.

Also Issue logged here - http://www.steinberg.net/forums/viewtopic.php?f=230&t=70250 . I’d encourage everyone with this issue to add to that post too.

I have just experimented with disabling ASIO Guard for Vienna Ensemble. Whilst this is possible, delay compensation gets screwed up so this isn’t really an option. The only workable solution is to turn AG off altogether for me (even with Low I get glitches switching tracks). Really hope a solution is found for this.

Incidentally, I heard today that someone has found VE Pro 4 works fine, so does seem to be VE Pro 5 specific. Hopefully won’t be too long.

If that’s the case, then VSL needs to fix this VE-Pro 5 issue via an update ? hopefully they are looking into it, and will fix it soon.

yeah I noticed this too. have to have ASIO Guard set to Low, or off.

If you leave ASIO guard on and then change the Ensemble pro 5 buffer to zero instead of 2 or 4 does this make any difference for you guys?

Also, with the buffer on 2 or 4 if I arm record then disable it I geta horrible distorted noise. With ensemble pro buffer at zero this does not happen.

It is clear to me that Ensemble pro 5 buffer control and ASIO guard 2 are incompatible at this time.

Here’s an update from the guys over at VSL. Superb to get some developer feedback:

We have had a look into the situation with C8 and VEP, and currently there is nothing we can do about it, more than report our findings to Steinberg. When switching tracks in Cubase, the plugin can receive a new buffer size, and since VEPro has an inherent latency which is buffer-dependent, VEPro will have to report its new latency to Cubase. Cubase immediately responds to this by reconfiguring its audio engine - causing a pause in audio.



Logic Pro (and other software which is using variable-sized buffers) do not immediately reconfigure the engine when switching tracks during playback, which allows for uninterrupted playback. We will recommend Steinberg to implement a similar scheme.


Martin Saleteg
Software Developer
Vienna Symphonic Library GmbH

And

'I am looking into this together with a Steinberg developer right now, and hopefully we can find a solution.

Until then, I can offer a workaround to disable ASIO Guard for VEPro manually. You can do this by going to:

[Menu] > Devices > Plug-in Manager > VST Instruments > Vienna Ensemble Pro > Click “i” for Plug-in information > Click to set ASIO Guard to Inactive.

Please perform this operation on ALL VEPro Instrument and Fx plugins. Then also Audio Input plugins will work properly.


Martin Saleteg
Software Developer
Vienna Symphonic Library GmbH’

Thanks for posting this, for the time being it might be a good idea to disable it completely for VE Pro only. I’ll have a fiddle around when I next have a bit of time.

Uoww thnx saved my life

Maybe I don’t understand the issue completely, but as far as I can tell this problem appears to be fixed in the latest update (5.4.14074) of VEP released 6 Feb 16. The changelog of the update includes this statement: “Improved. Mixdown performance with Cubase Asio Guard 2”.

After installing the VEP update I activated Asio-Guard at the Normal level on Cubase 8.5.0, then switched Asio-Guard on for the VEP plug-in (VST3 version). I was able to switch between tracks with no muting delay. Experienced no audio dropouts or other artifacts. Not quite sure how to best measure CPU load, so I can’t report on that. At least it does seem that the VEP plug-in works now with Asio-guard 2 and Cubase 8.5.0.

Argo

Cubase 8.5.0 Pro 64, Tascam FW-1884, i7, 24Gb.

Hey cheers for update inf; shall be trying later and if this works it will be great :slight_smile:

Still happens here with the latest version.

I don’t know why I never managed to reproduce any of the problems that have been mentioned for months regarding VEP and Cubase.
I didn’t update VEP with the latest update only to try once again if I can see those issues. No way. No track muting when switching tracks with two instances of VEP, and apparently no mixdown problem with effects etc …
Maybe I have a problem with my installation because everything always worked fine ! :confused:
I’m worried !

What do you have your ASIO Guard set to? If you set it to LOW you wouldn’t have this issue (at least I don’t). If you set it to Normal there is a half second pause while the buffer changes between Cubase and VEP. Setting it to high makes it worse. I run at Normal and have grown accustomed to it.