ASIO issue Wavelab Pro 9.5

ASIO driver using Dante i/o can not handle Sample rate changes. I.E. 48K is my default but when using file browser to preview a 44.1 or an open 44.1 music track - the wavelab driver balks at the sample rate change and will not play anything other than 48K files. Adobe audtion as an example (older version too) can easily transition sample rates under ASIO and the same Dante hardware.
How is it the Company that brought us ASIO doesn’t handle this?
I must use the MME driver in this Windows 10 workstation to get all the functionality of Wavelab.

Maybe Audition is using a resampling stage, rather than changing the driver sample rate.
Are you sure your Dante driver is not set in mode ‘external clock’?

What brand with Dante interface are you using !?

regards S-EH

Leif, my experience with WL and ASIO is that WL works better the it runs the clock. My audio card is set to internal clock so when WL detects a different sample rate it changes the card clock. Works very nice. I tried using external (better clocks) and it was a nightmare. My 2 cents.

Thanks for the replies -
It’s true unfortunately Dante controller will not allow me to set the internal clock to Grand Master. Dante Via and Dante Virtual Soundcard are essentially the interface. Only the external Audinate and Rednet devices can be set to master and they are all at 48k, so the issue lies with Audinate’s Dante than with Wavelab. I believe Adobe audition is doing some resampling as how else could it work with both 48k files and 44.1? Both sample rates will play or record in Audition when Wavelab will complains the soundcard is in slave mode. When I check the ASIO setting in Wavelab Audio device control Panel the Sample rate option in Dante Via ASIO Control panel shows 4800 which is grayed out and otherwise locked. Same is true when checking Adobe Audition’s ASIO control panel. Dante Via is locked at 48K But Audition works at any sample sample rate, which is very cool but I can’t explain. I only wish Wavelab was as flexible. If I bring in a 44.1 file to Wavelab, it will import the file but does not resample. It just screws up the pitch instead.

I also use an interface that’s not easily changed from whatever I’m on. Therefor I use a resampler in the WL Playback Processing slot so I can quickly have WL play back whatever sample rate I wanna check out. It’s a workaround and I don’t use it for critical listening but it’s quick and easy…

That’s a great work around. Thanks for pointing that out. Works well for my needs however it doesn’t help when using the file browser preview feature. In a perfect world… :slight_smile: