ASIO Overload

Hey everyone,

I have been having issues with some higher track count projects (90+) and also not having this issue with others. I searched for my issue and none of the solutions have been any help unfortunately.

Basically it seems like once I have a certain number of plugins set up, my “Average Audio Load” meter just starts ramming itself repeatedly into the red/clipping part of the meter and it won’t stop until I bypass all my plugins via the mixconsole, only to start up again after I enable them. This has been an issue on 2/3 projects I have been working on over the last couple of weeks. To make it extra fun, it has been an intermittent issue. Sometimes it happens, and goes away for a short time, and sometimes it just sits there smashing that meter forever.
These projects have had all MIDI rendered, VST instruments removed early on in the project. I have tried multiple things that seem to solve the issue for a moment which I will list now.

-Firewire ASIO Buffer up. Way up. Didn’t help.
-High, Normal and Low ASIO guard
-Disable multi processing (NOPE. Bye bitrate)
-Disable C states
-Disable AMD Quiet n’ Cool or whatever
-Followed “optimizing Windows for DAW” guide on the Steinberg site
-Driver updates on ALL THE THINGS.

My PC spec are as follows:

AMD Ryzen 5 2400G - 3.6GHz
NVidia GeForce GTX 750 Ti - I have this running dual monitors
Focusrite Saffire Pro 40 (Firewire, have a proper chipset equipped)
Console 1 - Tried unplugging, no change.
Faderport - Tried unplugging and mixing without. No change.

Please help. I am at a loss on what I need to do next, it’s driving me insane. I have projects coming up I need to get done. Thank you.

I wonder if you have enough RAM. 8 Gig seems a bit small. My first thought is that audio is being swapped in and out of memory, but that would show up on the disk load of the performance meter, and you didn’t report any trouble there.

I would next suspect background processes. That might explain the intermittent behavior. Use task manager to see what’s running. Apps and services that use the internet are especially annoying. Windows 8+ have “active tiles” that browse the internet looking for updates on stock prices and basketball scores, so that you can be immediately informed of these vital developments. So, if that’s an issue, disable them. Anti-virus software can also slow things down. These kinds of issues are not specific to DAWs, so there are many articles about general Windows optimization out there that cover such things.

My 3rd thought is that 90 tracks is quite a few, so you should consider freezing them to digital audio, thus moving the processing out of real time. You can always unfreeze. Maybe there’s a buggy plugin. Find out which tracks are killing your audio performance, then fix or freeze them.

You could also freeze submixes. (This is probably not new to you, but just in case … There’s no way you can be working on 90 tracks at once, other than when adding an instrument from a big project template. For example, if you had a woodwind section with 2 flutes, a piccolo, 2 oboes, an english horn, 3 clarinets, a bass clarinet, and 2 bassoons, then that’s 12 tracks you could freeze as “woodwinds” (a single stereo track) while you work on percussion, say. Disable the 12 woodwind tracks. When you later decide to do something about the piccolo, you’d unfreeze woodwinds, make the change, and refreeze.)

Hey Colin thanks for your response!

RAM has been a suspect but going any bigger than 8GB is expensive so I’ve got it at the bottom of the list of things to try first. Funny you mention the disk load meter… because I noticed this morning that one keeps coming up and peaking. I’m not completely sure how I didn’t notice it before but that’s there… so RAM is likely my culprit here you think? I’ve also been working on smaller projects in the days since then, and it has started doing it more consistently across projects instead of just with large track volumes. I also noticed that it really starts to act up when I bring up the Console 1 interface… In task manager it points directly at GPU though.

I’ve done a few of these, but I’ll google it and see if there is anything that would have a bigger impact than what I’ve done.

Embarrassingly enough, for how often I have about this, I barely know anything about freezing tracks/audio but you can bet that I"m about to learn about it!

Thanks again for the response, and advice. Much appreciated!

Did you was able to solve your problem? there is 2020 AMD drivers.



or contact: