ASIO SCOPE solution

Under Windows (all versions), the ASIO driver for the SCOPE audio card (Sonic Core) has a conflict with WaveLab, that can be easily solved by adjusting the Windows registry, as follows:
unzip the file below and double-click on “AsioScope.reg”
That’s it (no need to reboot). (435 Bytes)

Hi There,
Thanks for the patch, unfortunately it does not work for me.
I am running Wavelab 7.2.1 64 Bit on a Win 7 64 Bit machine with Scope XITE 5.1.
Ran the patch and then launched Wavelab and clicked on Options/Audio Streaming Settings and it hangs.
Uninstalled WL and reinstalled it with the same result.
By removing the ASIO DLL files from the Scope directory I was able to select a driver (Not Scope ASIO of course).
Replaced the Scpe ASIO drivers in their original directory and it hangs again.
Any suggestions would be appreciated.

Indeed, the Scope XITE 5.1 uses another sonic-core driver.
I have updated the REG/ZIP file. Download and execute again…


Thanks a lot,
I can confirm WL can now select the XITE ASIO driver.

I ran the registry patch but Wavelab 7.11 still freezes when I select the Audio streaming settings under Options.
Running the latest Scope5-64bit version on Windows7-64

I just noticed the updated fix, downloaded and ran the reg file and
It works. Wavelab now uses Scope ASIO.
Good work.

works fine for me , thanks

I am happy with this solution!

“LODE A TE O CRISTO”!!! :slight_smile:

You are a genious Philippe

Wavelab forever and ever

Now it works


My Wavelab 8 used to freeze at startup. Thanks to this thread I found out that it is my SonicCore Asio driver that cause the trouble. If I deactivate the SonicCore drivers, Wavelab works as it should. Without the SonicCore Asio, of course.

I’ve downloaded and executed the registry patch found in the first post, but unfortunately it doesn’t work :frowning: . My SonicCore setup consists of two Pulsar II cards (6 DSPs each) and one Scope Pro (14 DSPs).

Any help is very appreciated.


The .reg file relates to specific IDs (look with a text editor). Maybe your Scope hardware has other IDs, try to make some registry search.