ASIO spikes after several hours of use

I’m a long time user of Cubase, since the VST 3.7 days, but this is the first time I’ve ever had a problem that’s really just got me completely miffed. I’ve created a video showing the exact problem as it happened today, this link is below.

The issue is that after I’ve been working in Cubase for a few hours, I start getting these random ASIO spikes. It happens regardless of whether I’m playing back, recording, whatever. It happens in nearly empty projects as well as big projects with lots of tracks and plugs. I’ve only found two consistencies; It only happens after I’ve been working for an extended period of time, at least a couple hours, and once it starts happening, Cubase ALWAYS crashes on exit. To cure it, I just close Cubase, usually having to force it to shut down, I wait a minute or two for things to clear out of memory, and then relaunch. Then I’m good for a few more hours until this craziness starts happening all over again.

Anyone have any ideas? I’m fresh out of ideas on this one and can use some suggestions… :bulb: :bulb: :bulb:

Here’s a video of the ASIO spikes in action: http://youtu.be/a-j4qhmQke0

My basic setup:
Win 7
quad-core i7 2600 3.6 Ghz
16 GB RAM
Nvidia GTX760
UAD2 Duo (2)
RME Fireface 800

Have you got a way of monitoring CPU temps? I wonder if there’s some sort of cooling/speedstep strategy kicking in?

Does a reboot give you a period of sanity again or does it reoccur quickly? ie is the first (cold) boot of the day always the best in terms of period of stability?

I was just going to suggest the same thing. That the problem presents itself after a while is telling. Wait till the issue starts and them run a temp checking app. If, as I suspect, your machine is over heating, go out and buy a bigger CPU fan.

Plus open the case and check there’s not a build up of fluff and dust on/in the various vents and fans. If there is get the vacuum cleaner out!

I had similar problem but got rid of it after I connected my CI2 into an USB hub with external power supply.
I think the problem could be that your laptop doesn’t provide enough power for an USB-powered audio interface.

What do you think?

That’s an interesting thought about temps, I’ll check on that. When I reboot after the spiking kicks in, it seems to be fine again. No different than the first boot up of the day. But I’ll monitor temps and see what happens.

Not a bad thought, but I’m on a desktop, not a laptop. It’s possible it is a power issue though, I’ll keep an eye on that, thanks.

Power supply issues tend to crash the computer however it is a possibility - have you got a cheap generic power supply or have you upgraded to something decent? I’ve insisted on using £80-£100 power supplies on every machine I’ve built in the last ten years and have never had a corrupt hard disk since - could be coincidence of course. The quality of generic power supplies have dropped drastically in the last 15 years. I’ve still got a couple of 60-120W power supplies from old IBM ATs - on my 'scope they are smooth as silk thanks to the high quality caps and one of them has a FET rectifier - how’s that for over-engineering! - shame they’re not powerful enough for anything these days. More modern units I’ve tested on various computers spike all over the place - truly horrible! I’m stunned a CPU operating so close to the limits of physics even boots on cheap nasty noisy power supplies.

So after some more extensive testing last night, I’ve ruled out a number of things, seems to have nothing to do with power supplies, core temps, or anything hardware related. I ran a project in C7 for several hours last night, not a single click, pop, or spike. Boot up C8, and within the hour start getting all kinds of problems again.

Finally, I’ve narrowed it down to this: UNCHECKING multiprocessing in the Device Setup pane completely solves my spiking problems. When it’s checked, I get spikes, clicks, and pops. Unchecked, smooth as butter. When multiprocessing is unchecked, it also shuts off ASIO-Guard, but I don’t think that’s the problem. If I leave multiprocessing checked but then disable ASIO-Guard, there’s no change, I still get spiking. Only when I completely disable multiprocessing do I get the fix I need.

:question: Why? :question:

I have an Core i7 quad-core processor. Why would disabling multiprocessing IMPROVE performance on a quad-core machine? And what, exactly, does multiprocessing do when it’s enabled/disabled?

The other issues, like bad psu , core temps, etc…usually creep up before an hour of use.

Onto ASIO guard and Multi-Processing. What I have noticed for me is it also depends on the audio interface.

With my Emu 1820M, the cpu load levels never spike and I get low latencies. With my M-Audio Delta 1010 it’s pretty much useless.

I get the same issue. I’m thinking memory leak with either cubase itself or one of the plugins.

I thought about a possible memory leak too, but I don’t see any RAM bloat in the resource monitor while this is going on. So maybe not…

I’m going to try a few BIOS tweaks later today when I get some time. Looking through some of the optimization guides, I’m seeing some suggestions to disable several items in the BIOS that I don’t think I’ve done. It’s worth a shot. I’m also going to try trashing my preferences file and rebuilding that to see if that helps.

If nothing else works, maybe I’ll just try working with multi-processing and ASIO guard off to see how things go. But I really feel like there is something in C8 that is far more sensitive to system setup than previous versions. If the same project runs fine in C7 but starts spiking after a period of time in C8, that seems to me that it’s an issue with the software being not quite robust enough for a variety of system setups. I’ll keep plugging away here, maybe I can help someone else if I figure this out…