ASIO Time Overload? What solutions are there?

Hello Cubase forums!

I apologize if this (probably quite common) problem has already been queried about a thousand times, but I’ve really been wrestling with it recently.

Firstly, I’m having difficulty understanding what exactly is causing the issue. Is it RAM? CPU? If I had better understanding of what it actually means, maybe I could come up with solutions, with your help. :sunglasses:

I’ve been monitoring CPU & Memory activity when the “overloads” start and it seems like neither of them are stressed. CPU activity is about 45-50% and RAM usage even less than half.

Relevant PC specs:

  • Processor: I5-2500K 3.30 GHZ
  • RAM: 8GB (although to my understanding, my 32bit Cubase will only use half)
  • At present, I have around 8GB space reserved on my hard drive (on which Cubase is also located on) while I work on Cubase.
  • Running CUBASE 5 on Windows 10.
  • Cubase is located on my main hard drive (not in external)

When I record, I use a lot of plugins, mainly BIAS FX, which is running on all guitar tracks, and there can be even 3-4 simultaneously, which is usually when “overloads” start, but not exclusively then.

Here’s more or less a general track layout:

  • 3-4 tracks running BIAS FX (+ some other Cubase native plugins)
  • Ezdrummer
  • Spectrasonics Trillian bass track
  • Cubase’s own synths (mostly Embracer)
  • Some misc. sound effects (.wav files)

    So there, I think I’ve provided all information I can, so if anyone has any suggestions, post them in this webzone :stuck_out_tongue:

It’s all about how hard you’re making your computer work.

Adding a big workload is one thing.

Also latency.

The lower the latency the harder the computer has to work.

So if you’re in the mixing stage you can raise the latency up and it should be good, but there are limits to everything.

If your project gets too big export a mixdown and open it in a new project with just that wav file and track to it then bring the new track back to the original project etc. There’s other ways to save processing.

Reducing processing or add processing power as well has adjusting latency, working within your limits.

You say “When I record, I use a lot of plugins, …”
This is a beginning of the answer… is mathematic , much / less. Too much plugins (I think) is amateurism. You have to take great RECORDS ,very natural and most clean as possible! Plugin’s aren’t make a bad guitar or bass record sessions turn to good tracks! Too much plugins and virtual drum will be overload your system. Convert your MIDI drum Track in WAV, and re-import, so you don’t need to charge VSTi in memory in this project. And think how much Plugins you really need. Good luck!

Thanks a lot for replies so far, guys.

This is actually a pretty interesting solution, I’d never thought of it before.

Could you also explain how adjusting “latency” works? We’re talking about the buffer size, right? I haven’t touched it yet.

I’m currently in the recording phase, so is there some kind of optimal zone latency-wise, where I could still record and have accurate monitoring?

Thank you very much, I will try this.

//Could you also explain how adjusting “latency” works? We’re talking about the buffer size, right? I haven’t touched it yet.
I’m currently in the recording phase, so is there some kind of optimal zone latency-wise, where I could still record and have accurate monitoring?//

look at Cubase Folder, an executable “ASIO” panel. So, you can choose the buffers sizes and other’s options. And… think in a SSD Hard Disk, is muuuuuuch better performance in all parameters.

Thank you, but before I start adjusting buffer sizes and what not, I’d like to know what they are first. I have no practical or theoretical knowledge of what latency is, except that it affects your monitoring. I’m new with this.

Several things go into making a music computer.

Like you want a dedicated machine, no animated cursors or background internet junk, you make the machine lean and purpose built to make music. You shut down unwanted services in computer management section . Anything not music related lowers your potential for music.

When you buy an audio interface it has a latency adjustment(buffer). When you hit a key on your keyboard, it sends a midi note to a virtual instrument then the instrument makes the sound, then the sound goes through any plugins and out to your interface to get converted to analog and amplified for your monitors. All that takes time. So maybe your computer could make that sound almost instantly with a very low latency setting (close to real time).
That’s fine as long as you only want to play that one note. But if you want a bunch of track and a bunch of instrument your computer can’t keep up.
So if you buffer the process and give your computer the time it needs to complete all the tasks you’re asking of it - it will be able to do what you want.

So setting the buffer/latency is a process that you usually only need to do once. You try a setting and keep lowering it until you have artifacts which are pops and click and things that are a sign that your computer can’t keep up with what you’re asking of it. Then raise it back up where it was working and that should be your tracking latency. If you’re in the end stages of a song and have too much going on for that latency you raise it up.
Lot of people have different settings depending on what their doing.
Low latency is mainly for tracking, recording while listening to existing material or playing a keyboard without a delay in the sound generated.
Mixing and mastering can be high latency so you can add more processing.

Thank. You. That was amazingly informative. This should be a mandatory read for anyone who’s new into music making.

So I went into Cubase Control Panel and changed the buffer size from 256 to the maximum 1024 and now the overloading has stopped. (Sorry if I’m getting the values wrong, I’m at work at the moment.) Thank you again.

I just have one more question. I wondered how much is there a difference between recording 44k or 48k and if it affects the performance as well? I’m going to spend a lot more time optimizing my PC and Cubase now.

There’s different opinions on that.

I personally feel that working at 88.2k or 96k is a waste of resources.

Certainly it is in my situation and for what I do. Maybe some studio’s need that much extra fidelity but for me it sounds the same.

Nod is as good as a wink to a blind horse.

I work in 48k because that’s the internal sample rate of my interface and it seems to work better.

Try both 44.1k and 48k and see if you can tell a difference or if one works better.

Traditionally you would choose one or the other to match your target sample rate, like if you’re creating a CD you’d use 44.1k or 48k if you were making something for film etc.

I’m just creating regular songs to be released online so maybe even 44k would be sufficient. Not a big production, just bedroom recordings basically.

Where can I find out the internal sample rate of my interface? I’m using Focusrite Scarlett 2i2 (1st gen).

An update on the original situation, the overloading has once again started when I began to test my bigger projects. The overloading is so bad now, that Cubase is basically unusable. I was monitoring the situation, and I learned that my hard drive is working at 100% capacity when I open my projects in Cubase. So now I’ve found the definite cause, my hard drive is failing.

So I remembered what CrisNich said earlier;

This will likely be the solution. I’ll get an SSD and migrate my old drive on it. My current hard drive is aeons old, so it’s kind of stupid it wasn’t the first thing I looked into. I have done major optimization on the PC and Cubase now, so when I can get an SSD, it should solve all the problems as far as the overloading goes.

Not using a stone age version of Cubase that was released before Windows 7, was not optimized for your OS, and is missing almost 10 years of performance improvements and bug fixes might help.

Fair point, but it has actually worked great thus far, the issue as stated in previous post is the old hard drive crapping out, not an OS/Software incompatibility. I’m pretty shocked how well it actually runs, like you stated, it’s been almost a decade since release. Cubase 5 is a true workhorse.

I’d love to upgrade obviously, but it’s not a possibility at the moment, so I must work with what I have.

i would like to say that i have seen a system with core i5, 3.0ghz,3.0ghz with 8GBram doing great with several VST on cubase instrument tracks.

however, i have corei7, 2.98gz,2.9ghz turbo with 12GB ram ,Audio interface focusrite 2i4 doing very poor with several VST on cubase instrument tracks.
please what can i do to solve this ASIO time overload problem.