ASIO Usage Red Lining

Hi,

I am experiencing quite a strange problem with Cubase 10.0.20 Build 187. I have Omnisphere playing 5 tracks and all sounds okay and the Performance Meter is not even at 50%. I save my project and when I reopen it the Performance Meter spikes to 100% randomly and when I try to play the project the audio sounds slow and very distorted. The meters at this are both clipping at 100%. If I freeze all the tracks then unfreeze them everything returns to normal and the project will play, the performance meters are again registering no more than 50%.

I have played with increasing buffers but this doesn’t change anything. I have added to this post my Cubase settings and those of the RME Fireface UFXII audio interface that I use.

Any ideas are thoroughly welcomed at this stage as it is something that is baffling me.


Strange that it comes back to normal after such operations like freeze/unfreeze etc. Anyway 32 samples buffer is a really really demanding task with plenty of VSTis running.

There should be a difference when you increase buffers, you say it isn’t. Are you sure?

Thanks for your post. I have uploaded a video which demonstrates what is happening. You will not hear any audio playing as it is a live project that I am working on. In this little test the buffers were set to 256: https://youtu.be/bGfUsZbNCG8

After a little more troubleshooting I have narrowed it down to the Fireface UFXII, as the problem went away using the Generic Asio driver in Cubase. Again any hints as to what it may be would be most welcomed.

Okay, replying to my own thread here I know. :laughing:

After a little more trouble shooting I think it may be an MMCSS Priority issue. Running the mmcss-test tool from Steinberg’s knowledge base article it starts with 128 threads but limits the test to 32 as 96 of them failed to be set. So it looks like my system is stuck to 32 threads.

Hmmm, have you simply tried another USB port for the Fireface? RME drivers are the big boss of drivers, some USB chipsets aren‘t. On most mobos there are at least two of them, some are really just good for copying files :slight_smile:

Maybe also take a look into the RME forum. Stuff like MMCSS has been discussed there, often with great tips.

https://www.forum.rme-audio.de/viewtopic.php?id=27987

Thanks for that useful link, very interesting.

I have tried both the USB 2 ports I have available and the USB 3 ports but all have the same effect. It’s really odd and I have reached out to Steinberg support as it has almost beaten me into submission.