ASIO4ALL has suddenly stopped working

Something strange happened today. I have installed a new (screen) monitor, and since then the ASIO4ALL Control Panel won’t open, either in the Taskbar or via the Studio/Devices menu in Cubase. ASIO4ALL does still work with all my other programs, which is odd, to say the least.
If I click on the ASIO icon on the taskbar, nothing happens.
My workaround as I need to carry on with a project, is to use the Generic Low Latency ASIO Driver. It works, but it’s not as good or as controllable as the ASIO4ALL which I have used for years.
I do hope that someone has already solved this.
Any suggestions?


When you say

Do you mean you installed software for it? If so uninstall it, and check.

No software installed, just a new monitor.


What troubleshooting have you done so far?

Are you certain that the new display causes the problem?

Just checking whether you installed any Nvidia graphics drivers before connecting the new display?
These drivers include their own audio “devices” (unless you do a “custom install”) and they totally bu**ered up a previous music PC. This is assuming that you’re using Windows…if not please ignore me :slight_smile:


1 Like

good point.

Also, fiddle with the default audio device in Windows, in case for some (wrong) reason it’s locked to a program or driver, or whatnot.

I think that the new display is coincidental, and hasn’t caused the problem.
I have run the Microsoft sound troubleshooter, which failed to find anything.
It would seem to be a clash with Cubase (on Windows 10), as ASIO4ALL works with all my other programs.

I am baffled.

No, no new drivers or other software installed.

I have tried all sorts of adjustments to my sound settings, but none of them affected the ASIO4ALL problem, which only occurs when running Cubase 12 Pro.

I’m stumped.

Just guessing here, throwing out basically random troubleshooting steps…

Have you ruled out corrupt prefs? (Cubase Safe Mode disable prefs)

Was there a recent Windows update on your machine?

What is the sound device? (Not that it matters, but who knows maybe something will click for someone here…)

I’ll try Safe Mode disable prefs tomorrow.
As using the Generic method works for now, I’m happy to stick with that, but I will keep trying to solve this because I hate being stumped. If I resolve it, I will post the news here. I see from the Forum that this has happened to (a few) others, so let’s hope for a “hive mind” solution.

1 Like

Hi, Steve and others.

I am delighted to report that I have fixed the problem with ASIO4ALL and Cubase 12.

It wasn’t absolutely straightforward, but it does seem to be properly sorted out now.

In case anyone else has the same problem, here is what I did:
This is for Windows 10 64 bit, running Cubase 12 Pro.

  1. Open Cubase 12 in “Safe” mode. (Click the “Disable Preferences” box.)
  2. Select “ASIO4ALL” as the ASIO driver
  3. Continue to open Cubase.
  4. Click on the ASIO4ALL icon in the taskbar. The settings box doesn’t open, and the icon disappears!
  5. Exit Cubase
  6. I uninstalled ASIO4ALL
  7. I reinstalled ASIO4ALL
  8. Reopened Cubase in safe mode, but ASIO4ALL wasn’t listed as an ASIO driver.
  9. Restart PC.
  10. Restart Cubase in normal mode. No ASIO4ALL icon on taskbar!
  11. I copied my ASIO4ALL Folder from my “Program Files (x86)” folder to my “Program Files” folder.
  12. Restart PC
  13. Restart Cubase in safe mode, disable preferences.
  14. Go to “Studio” menu, then “Studio Setup”, and click on the down arrow in the ASIO Driver box.
  15. Select ASIO4ALL, which has now appeared as a choice.
  16. Back to “Studio” menu, select Audio Connections, and select ASIO4ALL as the Audio Device.
  17. Close Studio menu.
  18. ASIO4ALL icon has now reappeared on Taskbar, and when clicked, the settings box opens as it should!
  19. All fixed!

Anyone having the same problem only needs to copy my actions from 6 to 18, but I thought that I should show my thought processes. I have absolutely no idea what caused this malfunction, but I am very relieved to be able to get back to work.

Good luck, and thanks to Steve for his ideas.


Great sleuthing!