ASIO4ALL v 2

Everything was working just fine before I tried to switch Input to another driver.

But now that I am trying to return to the direct Fender amp connection via ASIO4ALL v2, I am able to use LT USB Audio Streaming as Input, but Output **only has NO CONNECTION 1 and NO CONNECTION 2 as an option.

What can i do to correct this?

I am unable to select anything under Device Port when ASIO4ALL is selected as Audio Drive. This was not the case before yesterday!!

If you use ASIO4all you need to setup ASIO4all.

do you set up ASIO outside of Cubase?

I go to the ASIO folder under Program Files and only see ASIO connecting to the microphone, not the Fender amp.

Dammit this is frustrating. Input is working just fine since the Fender amp is directly connected, but Output will not connect. %$@!

ASIO is Cubase’s ‘audio system’ basically. On Windows, you need to use an audio interface with an ASIO driver, not a WDM (or whatever its called nowadays) driver. If your interface doesn’t have its own ASIO driver, you can try to use the third-party ASIO4ALL which acts as the ‘translator’ between Cubase and your interface.

ASIO4ALL has absolutely nothing to do with Steinberg and isn’t written or supported by them. Its a third party utility made to be a ‘band aid’ for people that don’t have proper ASIO drivers.

Hi, Robyn. On the Studio Setup dialog window (as the screenshot you posted), you should click the “Control Panel” button to launch the ASIO4ALL control panel dialog.

Usually, it is set to standard mode, but if you click the gear wheel button it should switch to advanced mode, which in turn it will list both the audio devices’ names and their individual input/output groups.

I don’t know how your audio interface is set up and how many i/o groups has, but usually there are at least 1 input and 1 output. On the worst case scenario, there’s a restore all button which should reset everything to default values.

Please bear in mind to check also that you did not accidentally disabled any of the sound inputs and outputs in the Windows Sound control panel, or it will play back nothing anyway (tried myself).

1 Like

This screenshot doesn’t show ASIO4All, it show Steinberg’s Generic Low Latency Driver.

Robyn2020 -Hi!

In ASIO4ALL
Click the control panel in ASIO setup for ASIO4ALL
Select all OUTPUTS from the menu within the ASIO4ALL settings (Select the advanced settings - the cogwheel far right bottom)
Select your LT USB and select all outputs.
DISABLE MIC inputs if not used

In AUDIO SETUP
Select ASIO4ALL as your output.
(All you LT USB outputs should now show)
Click on DEVICE PORT and select output 1 (Left) and output 2 (Right)
ASIO4ALL should now work.

Hope this helps

-=DARCHY=-

Actually, Steinberg used to support ASIO according to ASIO’s website - and my problem was solved as soon as I re-installed ASIO. Works like a charm :slight_smile: :grin: