At my wits end with vst performance...please help guys

I just can’t take it anymore. I don’t know why but I just cannot get Cubase to run smoothly on my computer. And I have a pretty slick computer. All SSD Drive, I 7 3930 K processor, windows 8.1, 32 gigs of really fast RAM.

When I load a vst…any vst…and let it loop for a minute while playing, it slowly rises in vst load until it crashes the performance meter.

Any ideas?..because I am just plain out of em. Been happening since 7.

I have a pic of my computer maxing out with 1 instance of kontakt…but I don’t know how to post it. Sorry.

Do they do the same in stand alone mode.
Do you have a dedicated sound card.
Internal sound card supplied with the pc are NO good.
Have you set to sound card asio.
Mike001

With Kontakt you could try turning off multi-core support within Kontakt preferences. Kontakt runs a lot better like this. This was advice given to me by NI support.
Like the previous poster we will need a bit more information.

Hi Bigboi

I’m posting this just in case. I had a similar problem, couldn’t find an answer, eventually checked on the temperature of CPU (won’t bother with the how and why). It was running waaaaay too hot and the moment I got a decent cooling system the problem went away. Used a free app from the net for the temperature btw.

Best Regards

Dave

I just upgraded from Win 7 (64bit) to Win 8.1 (64bit). Performance in C Pro 8 was actually quite bad beforehand. CPU spiking, Stuttering with VSTIs etc. Upgrading Windows (for me) was a great chance to cleanly install everything again. I updated my BIOS. Actually updated every driver and installed every update for Win 8.1

Then downloaded the full C Pro 8 installer and then the 8.0.5 C Pro update.

I then followed this “Tweaking Win 8.1 for Audio and Music Production” video.

https://www.youtube.com/watch?v=PhQVkv3NM3k

C Pro 8’s performance is now AMAZING. Obviously still has a few bugs but hey, I’m sure future updates will sort them out.
Sorry if none of this helps but I would definitely start with making sure you have latest BIOS and chipset drivers installed.

Also, in Kontakt 5, you should definitely have Multicore switched off if its not being used in standalone.

Jono

Sorry for not giving you guys enough info initially.

I have a recording studio in midtown Atlanta (www.solidsound.com)

I have 2 Lynx Aurora 16 converters…great cards. Running Asio drivers…the problem is there at any buffer (obviously less when I up it to like 500 or 1024…but who can work at those buffer sizes?)

I have found a couple of oddities tonight while spending the last 3 hours trouble shooting:

  1. After loading Kontakt and the library (a 64 meg library, btw), it immediately blows up. Now, here is the weird part. If I turn the record arm off for the track, the pegging drops off…I mean totally down to nothing. As soon as I arm to record…BOOM…MAXED OUT.

  2. Also, if I turn of the record arm button, select a different track, then select the original Kontakt track again, the record arm button is automatically back on again. Basically, there is no way to unarm the track and have it stay unarmed.

I don’t have these problems in standalone mode. I also can load up Sonar X3 and run with no issues either. It’s only in Cubase. I sincerely thank you for your ideas…keep them coming. Do you think I should reload Cubase from scratch? That channel arming thing can’t be right can it?

Have you disabled Kontakt’s multi core option? You really need to do this.

If all the optimization and troubleshooting proves not to be enough, and you’re looking for a new PC build, the Intel i7 4790K runs at stock, at 4.4 and can easily be overclocked to 4.6 with an inexpensive watercooling fan replacement.

Cubase / audio plugins run like WILDFIRE on it. Especially with ASIO Guard 2.0 enabled.

And it runs stable (no blue screening), even with ASIO nearly maxed.

There is non-linear performance gains with floating point with these new Devil Canyon processors.

It gives more bang for the buck than we’ve ever had before, in terms of performance percentages over the base clock, for floating point (what plugins and Cubase wants).

It can be had for under 300 bucks.

I can’t offer a solution to your problem, except to say I am using the same 3930k processor on a Windows7 computer, and am able to have multiple plugins and tracks with loads of headroom (usually not going above 30% with low buffer settings) on the VSTperformance meter. So my first thought would be that your problem is definitely not a processor one.

YES!

Have you any Midi Time Clock (MTC) running ?

I have disabled mulricore AND have no time code running. I’m so stumped.

Oops, correction: Your 3930K was somehow lost on me. I was thinking it was an older gen processor.

My advice on the 4790K is mostly null and void.

That said, the fact it can be overclocked easily to 4.6 would probably outperform the 3930K’s six cores at stock (you have six, right?).

But only a test would confirm.

You could try putting a watercooler on that 3930K and OC it. Even 200 mhz OC on a six core would result in dozens more real-time effects.

The other thing you could try is swapping out certain plugins for less CPU demanding ones.

For example Slate Digital VMR is extremely low CPU for how modern the algorithms are. I think I tested something like 50 instances of the VMR Neve emulation for 1 Waves 1073 (their recent version) or IK Multimedia 73 (or something like that). It was substantial.

The Waves SSL Channel is very low CPU, for example, and does a lot.

Get a copy of Reaper so that you can use its excellent channel / plugin performance charting features to see, precisely, how much each plugin uses on your system.

The difference in CPU between plugins is quite dramatic and can really add up.

Have you tried starting Cubase in safe start mode? See this link in the Steinberg knowledgebase if you are not familiar: https://www.steinberg.net/en/support/knowledgebase_new/show_details/kb_show/safe-start-mode-resetting-the-cubase-preferences/kb_back/2020.html?tx_p77sbknowledgebase_pi1[filter_2]=17

Have you created a support ticket under mySteinberg? I suggest that as a support agent here in the US will call you. Its part of what you pay for when you buy the software and a great resource. Messageboards can be helpful, some times less.

I will open a ticket tonight.

Also, is the auto arm thing normal? When you guys select a track, does it auto arm for recording?

For your viewing pleasure:

http://youtu.be/OHXqPoayo6k

I have no idea man…just none. Without reloading my entire system (which will take a month), I am not even sure where to go to trouble shoot it. Then, if I reload it, whose to say they problem is not right back?

First, it doesn’t matter that it’s not playing. The audio engine is working even when it’s stopped. And, there’s nothing wrong with your system.

Here’s what’s going on…

The higher CPU load with Record Enabled is normal and how ASIO Guard 2.0 works. Just leave Record Enabled off on all the channels (except for the one you’re currently recording on).

Since ASIO Guard is a dual buffer system (a large buffer and small one for low-latency stuff) that smaller buffer (for Recording at low latency) is the weakest link in the ASIO-Performance-Chain, as far as the meter is concerned.

You’re seeing your CPU try to crunch 4 VSTi’s into that smaller “Record Enabled” buffer.

To make matters worse, my guess is that the smaller buffer used for low-latency recording has to “fit” all on one CPU core (you have 6 cores).

Another way of saying this: my guess is that only the larger buffer (non-Record Enabled tracks with ASIO Guard on) gets to enjoy splitting up the audio workload across cores (a.k.a. multicore “audio scheduling” is the technical name for it). This is how Sonar’s audio engine works.

So it’s many things working against you:

  1. The smaller “Record Enabled” buffer (with 4 channels trying to squeeze into it).

  2. The strong likelihood (based on the evidence) that Cubase has to do all that work on a single core, whereas when you uncheck Record Enable for a given channel, it can not only shift to the larger buffer, but shift across other cores.

  3. The fact that Intel CPUs with higher core counts (6, 8, etc.) tend to see lower performance per-core, but greater overall performance due to the extra cores. So, if my suspicion that #2 is correct (and I think it is), then you’re trying to squeeze those 4 channels on a single, lower performing core (compared to cheaper 4 core CPUs), at that. So the premium 6 core CPU may be hurting you a bit for this use-case. A cheaper, 4 core of the same generation and same clock speed may have just enough more performance per-core, to pull it off (or not).

Overclocking would probably solve the issue then, because you just have to get a little more juice out of one core.

But, if you can, just disable those Rec buttons (except one). Problem solved.

(There’s a pref setting to turn off the auto-Record-Enable that will make this easier.)

But it craps out with just one instance of Kontakt and a medium (400 meg) instrument. This just can’t be right. How can anyone work like that? If that is truly the case, I will have to leave Cubase. Man…I am really depressed at this point.

A rapid read of this thread shows me that this hasn’t been mentioned (sorry if it has!) but are your CPU settings in “Control Panel > Power Settings” set to “High Performance”? If not, this could definitely be your problem.

High Performance sets your CPU cores to max and avoids core parking and SpeedStep. It turns out that if you can get quite granular in the power settings of Windows 7 (probably W8 as well). If you go to “Change plan settings” and “Changed Advanced Power Settings”, you can see some but not all of the parameters that can be adjusted (check this page). A better utility for this is ParkControl, but even that doesn’t cover all the options which you can only see directly in the registry or using some advanced sys info programs.

IMO, Steinberg should set up some ideal power settings for W7 and 8 and make them available to their users. I think a lot of reported issues regarding performance have to do with this. On my system, the difference between having power settings on “Balanced” and “High Performance” is dramatic, stuttering and glitching vs smooth sailing.