At the risk of a scolding/hand slap: NO AUDIO/NO MIDI

Now I did get the HAlion Sonic SE routed thru my interface, comes out the speakers like it should, & it will play (mouse clicks), but it’s not picking up my MIDI controller. And I can’t enter notes from the controller either. Also, seems like I should be able to click on a note & it would sound. Not happening.

So, if your 1st question is “Is your MIDI keyboard set up?” I would have to say “no” because I’m not finding a clear explanation in Dorico help as to how to do that.

Seems like the keyboard did work with the 1st version, but I’m not saying for sure because that was awhile back, & I’m just now getting time to learn Dorico.

But I really don’t want to go deeper if the controller won’t enter notes in Dorico & I can’t hear the notes anyway if clicked.

Please be gentle, & thankew for your time.

Sorry to hear you’re having problems with your MIDI keyboard. Getting your keyboard to work should be as simple as connecting it to your computer before you run Dorico, then run Dorico. As of the new update, there is an additional option in the Preferences dialog to enable or disable support for MIDI input, so make sure that is set appropriately.

If that doesn’t help, you will need one of my colleagues who knows how to read the various log files written by the VST audio engine to weigh in. Please zip up the VSTAudioEngine_64 folder from %APPDATA%\Steinberg (assuming you’re on Windows) and attach it here, and I’ll ask Ulf to take a look on Monday.

Hi Daniel,
I’m also having the same problem. Everything was working prior to the update, now there is no sound nor can I input with my midi controller. I’m using a Novation 49SL MkII midi keyboard. Tested the keyboard afterwards with Cubase, Finale, Sibelius, Reason, Sonor and everything is working fine. Any help with this would be greatly appreciated.
Please see file.
VSTAudioEngine_64.rar (1 MB)

Okay, I seemed to have figured it out. At least I can input and hear back my input. I got this from another thread
Play > Apply Default Playback Template
That seemed to kick in the midi functionality.

diamondknife, I’m afraid, as I say, I don’t really know how to parse those VSTAudioEngine logs, but it does appear to my untrained eye that no MIDI devices are found on your system. You could try trashing the VSTAudioEngine_64 folder and then restarting Dorico to let it recreate it, and see if that helps matters at all.

Just FYI,
I’m really not having any problems with my midi keyboard thru Sibelius.

I’ll try the above suggestions. Thanks for the replies.

That did it for me, diamondknife! MUCH thanks for getting my MIDI keys to do input on Dorico. Playback’s coming thru my interface/speakers as well.

Though I’m compiling a lot of “hmmmm’s” at this point (because I can hear it), right now it’s about just learning how to get around. And then again, I can’t move forward if I can’t hear it while inputing. That said:

Thankew again, diamondknife!

I’ve just started to use Dorico and I cannot use MIDI keyboard for input.

There’s nothing wrong with computer keyboard input.
Other applications (eg. Logic) definitely recognizes the MIDI input. I connect and switch on the keyboard before running Dorico and the preference “Enable MIDI Input” is checked.
“Play > Apply Default Playback Template” trick doesn’t work for me.

I’m using Mac (OS 10.11.6) and Dorico
I’m totally lost… :blush:

Daniel: as for Preference, I’d like the option to be able to add the keyboard after Dorico is started.

Can you zip up the VSTAudioEngine folder from ~/Library/Preferences/ and attach it here? My colleague Ulf should be able to take a look and figure out what’s up.

No need to be embarrassed, we are with you :wink:

So your problem is only MIDI input, right? You do get sound when playing back a piece?

For the MIDI input, it should be really as easy as connecting the MIDI keyboard and starting Dorico. Dorico resp. the audio engine shall automatically detect all MIDI ports and use any of them for accepting input.
One little detail though, you have to double click in a stave for MIDI input to start.

If that doesn’t do, please do as Daniel suggests and zip up that VSTAudioEngine folder. Also, you could create a simple Piano project with just a handful of notes and include it in the zip.

Thanks a lot, Daniel and Ulf!
Yes, I can playback a piece written with computer keyboard.
I attach the zip file. (533 KB)

Thanks for the data. From the log files and the project file I can see that the audio engine doesn’t recognize any MIDI port on your system, so no wonder that MIDI input doesn’t do for you. As to why that is, that’s a mystery.
I have to consult with other colleagues on Monday, so please wait a little…

I actually have the very same problem… and I should confess I am quite angry at Dorico!!!

After being a little bit (euphemism?!) disappointed by the very first beta of Dorico (let’s face it, it is indeed a beta ; I don’t mind using a beta, I actually applied for the beta tester program… but be straight about that :smiley: ), I wanted to give it a new try this morning after having installed the recent update… No luck, I’ve already wasted half an hour of my time… Back to Sibelius… See you in a few months…

We think we have a solution to the issue that no MIDI input gets recognized. The fix will be in the 1.0.20 update that is due to come out next week. Please try with that and shout out, should it be still an issue.