Audio clicks and pops Windows 10 HELP!

So,

For about a month or so, I’ve been getting clicks and pops randomly while recording or sometimes just playback. I can’t say what changes were made when this started happening. I’ve updated my bios, updated my graphics card drivers, ethernet drivers, Apollo interface drivers…etc. Nothing seems to fix the issue. Below are my system specs and some DPC Latency Mon results. The biggest culprits are dxgkrnl.sys and Wdf01000.sys. I’ve tried googling and can’t find an exact suggestion on what to do to get fix the issue. Anyone ever experience this or know how to fix these issues PLEASE let chime in! Let me know if I’ve left out any important info. THANKS!

Audio Interface: Apollo Firewire
Graphics Card: Nvidia GTX 650TI (Running 3 monitors)

\


Computer name: DESKTOP-T3HEMMK
OS version: Windows 10 , 10.0, build: 16299 (x64)
Hardware: Z97X-UD3H, Gigabyte Technology Co., Ltd., Z97X-UD3H-CF
CPU: GenuineIntel Intel® Core™ i7-4790K CPU @ 4.00GHz
Logical processors: 8
Processor groups: 1
RAM: 32627 MB total



Highest ISR routine execution time (µs): 56.27850
Driver with highest ISR routine execution time: dxgkrnl.sys - DirectX Graphics Kernel, Microsoft Corporation

Highest reported total ISR routine time (%): 0.336566
Driver with highest ISR total time: Wdf01000.sys - Kernel Mode Driver Framework Runtime, Microsoft Corporation


Forgot to mention i’m running Cubase 9.5.10

Uninstall Nvidia completely, run installer in custom mode and deselect all except the main driver.
Make sure power management is on high performance.
Maybe worth trying installing and choosing the Windows legacy f/w driver too…particularly if you had done this before, Win update could have replaced it.

Check in Device Manager and see if windows has added any other audio drivers. Turn off all of them except for your device.



Thanks for the reply guys. I did what you both of you suggested. Just started a 4HR session. We’ll see how it goes. THANKS!

Unfortunately, minutes into the session, the clicks and pops were back :frowning: Any other suggestions? Thanks

Try plugging a single monitor to the mobo header and running on intel graphics. Disable the Nvidia. You have to keep testing to try and narrow down the problem, throwing random tweaks at it is no the way to get a solution unless you happen to get lucky.

Graphics is certainly chief suspect with the little we have to go on so far.

If you updated your Bios have you been in and made any bios tweaks since?

I had one monitor which clicked and popped until I replaced it. Are you sure it’s not your monitor? Does the popping come from both monitors?

Funny you should say that cause prior to updating the bios, I checked to make sure Hyperthreading was disabled and C-state and also disabled the video card in the bios. This stuff was already set when the issues started but after updating the bios, I haven’t gone back to check. I agree with you. I will try and run another test with the monitors later. Tough trying to test between sessions. Another thing I was going to test was my ram. but the monitors is a quicker way to go first. Thanks

Thanks for the reply. I’m not sure what you meant by the popping coming from the monitors. The clicks and pops are coming from my interface while i’m recording or playback in Cubase. I have 3 monitors. One is a 19" in my vocal booth that mirrors my 32" tv/monitor and a Slate Raven Touch screen. So I have alot of things that could be the culprits. All 3 monitors are going to my Nvidia card. Tonight I will disabling my Nvidia card and connecting the raven to my onboard video card. and see what happens. Then each other monitor 1 by 1. If that results in nothing good, I will then run tests on my ram. In searching the nvidia error im getting from Latency Mon, someone on the Nvidia forum mentioned they were getting this error and it turned out to be they had bad ram that was causing it. We’ll see.

Ok…So here’s where I’m at. I disconnected my Raven and my 19’ monitor and left the 32’ still connected to the nvidia card. Ran Latency Mon and still got Nvidia errors. I took the same 32’ and connected it to my onboard intel card, disabled nvidia card in device manager and obviously the nvidia errors were gone. Still getting wdf01000.sys errors and still was getting clicks and pops on a session that def should not be getting them on. FML right now. So I enabled the Nvidia drivers just for shits n giggles with nothing plugged into it and it still came up with some errors when I ran Latency Mon.

At this point, I have no clue how to fix the Nvidia issue. Does that mean I need a new video card? Could something else be causing the errors from that card? I still have left to check the ram. Please excuse my ignorance. I’m not that computer illiterate but im far from a pro. Thanks for any suggestions. Back I go to troubleshooting

Do you have just one FireWire port on your computer? I know some folks using a usb audio device had some luck with pops by changing USB ports. You also might increase the buffer setting on your audio settings. As for the nvida card, that is beyond my knowledge. Good luck!

I have 1 firewire card with 4 inputs. I’ve tried switching them but that was no help. My buffer size is at 256 which is high considering I was used to working at 128 without issues. Thanks for the reply

I had a huge issue with this after installing elements 9.5, turned out to be input and output were clocked differently,changed to both match, all good.

Finally got this issue squared away. There were a few things coming up in Latency Mon. Every time I got rid of one thing, there was another. Tested my ram and it was all good.

  1. I ended up removing the Nvidia card and began using my onboard intel card. That got rid of all the Nvidia issues.
  2. Then I started getting an audiobus.sys error coming up. I ended up having to go to device manager-view-resources by type-interrupt request-and uninstall it.
  3. Then the wdf01000.sys error was still there and even worse. The last thing that cleared that up and brought it down was disabling Avast antivirus software.

Knock on wood. My system has been running smooth ever since. Hope this helps anyone struggling with the same issues I was having. It was really annoying.

Ah, Was following this thread and would of pointed to drop any anti-virus. The built-in W10 anti-virus (Windows defender) works well and is in obtrusive.

Wish you had mentioned it while you were watching probably would’ve saved me some headaches

Why you need anti-virus, if you are using licenced software and don’t visit hacker’s and porno homepages? :wink:

The biggest risk for getting a virus these days is by adds, don’t install Java, and use a adds blocker in your browser to be safe.
Does not have to be a unsavory site, some of the biggest distributors of adds have had virus infecting adds in rotation.
Not something they are vocal about, and they get removed pretty fast, but it could happen.
The MS defender or what it’s called this year, is good at not getting in the way. If you exclude the Cubase folders and audio files from scanning it is not even noticeable.

I have clients that bring hard drives and flash drives every day. I don’t know what they have on their drives and more than once, my antivirus software has alerted me that they have a virus on their drive. This is why. All i use the internet for on my system is to send and receive files.