Audio connections disconnect when i change buffer size

Hi all.

I’m fairly experienced with Cubase. But recently - not every time, but it has happened now… when I change my buffer size, all my audio connections disconnect.

I am using C12Pro, Windows 10, Focusrite Clarett 4Pre and have been using the same set-up for years…

Any ideas?

Thanks in advance.


Can you try in Could you try in the Cubase Safe Start Mode [Disable preferences], please?

Make sure, you have the latest driver installed, please.

Hi, Yes, I uninstalled previous Focusrite driver, installed the latest one - which I think I already had, opened in Safe Mode, and it does the same…


What happens, if you set the Inputs, close- and reopen the Project? Can you see Missing Inputs again?

The Inputs and the Outputs are stored in the project. The Control Room is stored globally. So if you saved the project with Missing Ports in the passed, it will open with the Missing Ports again.

Hi. Exactly the same. I even did a new Back-Up Project… same thing, I open the project and it is fine, the problem is when I change my buffer size… and I just tried the same thing with my standard template… same issue.


I’m sorry, I’m running out of ideas.

Hi, @nikhollis

Not exactly the same issue, but well…
Sometimes, when I launch Cubase, the ASIO driver is not working (and even, but much more rarely, it stops working during a session) for a still unknown reason : the Audio performance meter goes down to 0 and no more sound of any kind. I tried several times to troubleshoot the issue (including driver updates), but never truely succeed until now.

This, to say that my usual workaround is this one : In the Studio > Studio Setup> Audio System panel, I click on the Reset button and wait for few seconds. Ususally the Audio performance meter comes back alive again and I retrieve sound in Cubase. Sometimes, I have to click on it twice or even three times. Something to try, maybe, even if loosing the Input connections isn’t the same issue : it concerns the driver behavior, though…

FWIW : RME Fireface UCX audio-interface (USB connection), Ryzen 7 3700 X with Windows 10 (22H2), Cubase Pro 12.0.60.

1 Like

@ cubic13

HI, that actually worked, in that when I changed my buffer it disconnected, but if I reset it all connected again, whilst being annoying, it is less annoying than connecting every output individually again, so thank you.

Still a pain though, that I didn’t have before… need to get to the bottom of it, someone on FB mentioned disabling ASIO Guard…

1 Like

On my end, the issue is occuring in a random way, no matter if the ASIO Guard is activated or not. But maybe it isn’t the case on yours : so, an added thing to check, maybe.

Thanks for the feedback… :slightly_smiling_face:

1 Like

I have the exact same issue with my Clarett 8 USB on Win 11. Just tried this:

Will report if it works…

I think these guidelines from Focusrite are good, but they did not solve my issue…
Did anyone find a solution? I also tried to reinstall the Focusrite drivers and software…