audio delay compared with plugin display

With WL9.0.25 on OS X 10.10.5 I get considerable delays between audio signals and the displays in the plugins of the master chain…

It depends not on plugin (tested with FF,Izotope and steinberg).
Even the build-in meterings are always too early compared with audio signal.

If I use buffer size of 32 samples it is minimal but buffer sizes of 2048 samples generates a delay of approx 200-400 ms.

I tested with cubase 8.5: no delay!
I tested with Logic and SO3: no delay!

Has anybody similar experiences? Or has a solution for that effect.

WL should not worry about this huge buffersizes and simply take into account the plugin latencies; should be the core function for WL…

I use the Focusrite 18i20 with current driver (1.8).

Some search in old forums told me that the effect runs under “latency or delay compensation for plugins”.

I had to notice that since 2013/2014 this is a big problem in WL!

PG insists that there IS a delay compensation for plugins but nobody can see this!

If you load a testfile that has every half a second a puls you can see this rather clearly.

Choose buffer size 32 and buffer size 2048 and compare: the metering runs up to half a second before the audio with a buffer of 2048…

As I said, nor cubase neither logic and SO3 suffers from this kind of error.

Better to repair this kind of error. No further cosmetics on the GUI and do not pump bells and whistles into this tool.
With this size of latency between audio and metering WL is more a toy than a tool :frowning:

I see the same here. This is probably a known issue. It would be good to see a fix for this.

Is this specifically related to plugins? I seem to remember delays in metering vs sound in Wavelab 8 on Windows with no plugins (on track meters I think), but haven’t really looked in Wavelab 9. Does it make any difference if you change the buffers in Wavelab or in the interface?

I have noticed the same problem here as well…

Couldn’t remember seeing exactly what you were talking about, but you’re right. It does it with the Steinberg Brickwall.

It you have a plugin with meters followed with a plugin with latency, the 1st plugin does not know this latency. Hence its meters are ahead. Is it what you describe?

All what is seen is already discussed in an old discussion.

See http://japan.steinberg.net/forums/viewtopic.php?t=45144

It is not only the metering of the plugins. It is also the metering of the integrated WL tools.

More buffer, more delay. Up to half a second delay between gui and audio signal.

@bob99: the mentioned buffer sizes are for my interface. you may have another kind of buffer setup controlling the latency (maybe not in samples but in ms).

We have seen so many changes in GUI since 2013/14, why not working simply on fixing that bug?
Don’t you think it’s crucial for that kind of software?
What about a car where the fourth wheel is always spinning of…?

Perhaps the cubase staff has some hints to solve this. Must be a way to solve this bug, others DAW do not have this.

Why do you think this is a WL software problem and not an interface problem? My Mackie interface is set to 512 samples and I am not experiencing the problem you describe. The response of the audio and the WL meters is immediate. Here’s my chain: Master rig on, no efx, GUI onscreen> Waves LinMB on and GUI onscreen>Waves SSLComp on and GUI onscreen>Ozone 7 on final insert running Vintage Tape and the iZotope ditherer on and GUI onscreen.

I can post a video clip on youtube if you want.

Go higher than 512 in the Wavelab buffer settings, 2048 or higher as described in the first post, and you should see the issue I think.
I’ve had to go there and higher at times when using very high sample rates, so it’s not unheard of.

I’m only using one plugin, the Steinberg Brickwall Limiter in the Master Section, and I see the issue with Wavelab buffer settings over about 2048. I haven’t tried it in other programs like Cheveyo has but they said it doesn’t happen in Cubase with changing buffer settings.

Bob, wait a sec. My external interface has it’s own sample rate setting and that is set to 512. Within WLE9 there are buffer settings (stock settings/default) of 16 and then a MME Specific Buffer Size window that is greyed out at 16384. I have not changed the settings in WL9.

Why in the world would I want to INCREASE the buffer number in WL when it works perfectly? And seriously, if the OP has done this to solve some latency issues and met with failure - then this is not the solution or the cause.

Yes, I am puzzled by the OP’s problems because I have a pretty minimal PC vs. his new Mac and do not experience what he is experiencing. To my way of thinking, the buffer size of the external interface is important in his case - yet he doesn’t mention this number. Is he USB, Firewire? In Cubase, where he says he has no problems, there is only the option for setting the external interface’s sample rate, nothing to change the Cubase software buffer number. To be honest, I am not clear why PG has included this option in WL because the default setting is working perfectly. I’ve never heard it explained why this is an option in WL9. What problems might it solve, I have no idea. Do you? Do you work with settings different than the default?

Thanks Mr. Roos, didn’t know there weren’t buffer settings in Cubase.

Cheveyo, are there buffer settings in Studio One and Logic, besides those on the interface?

But even if there aren’t, it still seems something odd in Wavelab if this topic has come up before, and this happens using just one plugin with the available high buffer settings. I know I’ve noticed it under working circumstances before, but didn’t note all the conditions at the time.

@mr.ross: don’t confuse Mac and PC. On a Mac you have to setup buffer size for latency in the DAW (in OS X the audio engine is integrated part of the OS) on a PC you have a possibility to adjust the buffer size on the Interface program.
Not much difference in effect.

The OP of the “first” discussion in 2013 was on a Win7 system. I’m on OS X. Both with different interfaces.

Both have the same problem.

For me it seems that the latency compensation is NOT working right!

@mr.ross: if you see not the necessity to enlarge the buffer size for you, believe me: there are good reasons to do so when you are working with several plugins! And I think it’s crucial for a sound editor program to handle the latencies of plugins correct.

In Logic and SO3 I was using the same plugins (on Logic the AU and not the VST version, but on Cubase the VST versions) and none of them have this problem. It’s probably NOT the error of the plugins.

cheveyo, OK, I will now think that your interface sample rate is Mac determined as it is plugged in - ha, something I do not have. Most multi channel interfaces have independent drivers to communicate with the computer. When this is not the case, it means there is only a stereo pair in and out. Is this what you have there?

Moving on, I do appreciate that you are having a problem, don’t misunderstand. My suggestions are made because I have at times experienced weird behaviors within recording software and had to figure things out on my own. Not to say that this forum has not been very helpful at times! :slight_smile: Sometimes you have to consider the total user community when you start to think that you have found a general flaw. Your problem seems to be shared by maybe ten ppl represented here - that’s not a large amount of ppl considering how many ppl use WL. More to the point, my point, what are the other ppl NOT having problems doing that allows them to experience trouble free operation?

OK, so three questions: #1, do you run your OS on an SSD, and #2, does your computer access the WL program and the plugins from an internal HD or and external HD? #3, how does your external interface connect to your computer? My answers are: Yes, internal SSD HD, and Firewire. I ask these questions because many times I read posts here where someone is experiencing problems and I come to find out they are using a laptop with external HDs and USB connected interfaces, or even built in computer interfaces. Now sometimes this can work for ppl, it happens, but sometimes it does work but not very well. One last question, have you run the DPC Latency checker on your DAW?

cheveyo, I also see this on the Focusrite site: see attachment.

Are you running Gen2 or Gen 1? Different drivers but I wouldn’t understand if this would make a difference. Where do you have the buffer sample set in this Preference window pictured below? Have you tried increasing this and decreasing this and leaving WL at it’s stock settings - 16/16384?
Capture.PNG

Hi mr.roos,

thanks for the research.
The screenshot you posted is for Ableton Live Lite Software for those people that have no DAW on their computers installed, so they are able to configure the interface. As I said you set the buffer from inside a DAW.

I have WL and some others DAWs on my Computer but NOT Ableton Live Lite :wink:
So this doesn’t help…

(Each audio device has one buffer so if you select the audio device and set the buffer size it is set.
From each DAW you can set a different value for your device but it is just ONE device.
You simply select this device with different buffer sizes…). I don’t think that it is a WL specific buffer as you said but perhaps only PG can answer this. I think this buffer size is simply a transparent way to the device buffer size…

I suppose that a lot of people will realize this misbehavior when they are looking for…
I don’t think that only ten people have this effect.

Did you try to enlarge the buffer (to max value!) and then see if metering and audio is in sync for you?

You can work with this error without realizing it. But once you realized it it is really annoying :wink:

This also should not be confused with standard latency of the interface.
Here the latency means the consuming time of a plugin. Same word but probably another field of programming…

For me the effect is present even without a plugin in the master section.

Simply enlarge the buffer to max and watch the WL metering (spectrum or peak or whatever)…

cheveyo, I am not sure that you have this diver thing sorted. Here’s two screen shots. If you have Cubase and WL you have to have the same options. Right?
Capture 3.PNG
Capture 2.PNG

I don’t think that they must be the same.

You can use Cubase with 512 and you can use WL with 1024 or whatever is possible.
Try to set the WL on the max value and try…
Then set the Cubase on the max value and try…