Audio disappeared ..

When I installed Dorico, sound was produced OK in write and playback mode, and I went along the learning curve.

Later on I wanted to transcribe a tune, using both Transcribe! and Dorico, and the problems started.

Dorico was sounding OK, but I had no sound under Transcribe! … Tried setting Dorico driver configuration (don’t remember exactly what I did but for sure removed the exclusive ownership of the driver), and Transcribe! worked OK, but funnily enough I couldn’t hear the audio in my headphone when it was plugged into the Dell WD15 dock station I use with my Dell XPS15, It only worked OK when plugging the headphone into the XPS audio plug directly

Later on, after a couple of days and a reboot of the XPS, there was no audio at all. Reinstalled the Realtek driver and audio is back but not for Dorico.
Tried modifying the Dorico driver config with no results. FYI, in Halion windows the vumeter movements indicate that sound is produced but not heard.
So this is likely a driver problem

Very weird !! Too bad that this fantastic notation software leads to these audio problems (never had any when simultaneously using Sibelius, Transcribe! and others

What can I do to fix Dorico audio… I hate the idea of going back to Sibelius …

Dorico version is 2.2.10.1256 with VST engine 2.1.10.328 … Is there a discrepancy between these.

That Dorico and the Audio Engine have different version numbers is correct.

What driver are you using? The Generic Low Latency Driver? If you open the driver panel, are there any output ports shown?
Could you maybe make a screenshot and post here?

Also, please create a simple piano score with just a few arbitrary notes, then choose Help > Create Diagnostic Report.
That creates a zip file on your desktop. Please send it to ‘u dot stoermer at steinberg dot de’. Merci

Thanks for your quick reply.

I use the geeneric low latency driver, and there are shown outputs. Driver panel shows there is also the RealTek ASIO driver but when I click on it nothing happens.

Further to your suggestion I created the small dorico test and created a few screenshots, also showing audio and sound device manager windows, plus the diagnotic report file. Screenshots and Diag report are sent as a zip folder "mhch4 Dorico Audio Problem.zip"to the indicated address


More on this…

I managed to get audio back from dorico by ticking the field “allow applications to take exclusive control of this device” realtek additional device advanced properties.

After doing this, when clicking on Realtek ASIO in Dorico device setup does activate this driver and Dorico playback works OK.

BUT !! now again there is no audio heard when running Transcribe! and VLC audio software tools. I understand that letting Dorico get “exclusive device control” of the audio driver prevents other applications to work OK.

I tried to untick this exclusive control property after Dorico took control and delivered audio. Dorico stills works OK and restarted audio apps still do not produce audio

So apparently this “exclusive control” thing might well be a source of problems.

For sure, music transcription, a very typical music activity, implies running Dorico to notate music and another application to control the playing of an audio file. There shouldn’t exist any problem when doing this, as it was the case when using Sibelius.

If your audio hardware doesn’t work properly with the Generic Lower-Latency ASIO Device when the option to require exclusive control is disabled, you might try ASIO4ALL instead.

If that doesn’t work, and using professional audio applications is important to you, consider getting some dedicated audio hardware, such as a Steinberg UR-22mkII USB audio interface, or another similar interface with good multi-client ASIO drivers, e.g. similarly priced interfaces from companies like Focusrite.

P.S. I’ve also gone through this shenanigans with audio working fine and then suddenly (after a reboot) not working fine. This is almost always due to a silent Windows/driver update, which is clearly not Dorico’s fault. Try rolling your Realtek driver back to a previous version.

Problem was solved thanks to Ulf’s reply to my email message with the Diagnostic Report who pointed out the potential problem of output formats for the audio drivers.

So I’m posting about it so that other Dorico users have a chance to be aware of it.

Problem was that the output formats of the Low Latency ASIO driver (it was 16 bits 44000 Hz) and the Realtek driver were different (it was 24 bit, 48000 Hz), i.e they were the default inslall formats which can be checked/set from the device property windows (Dorico , and Device Manager or W10 Sound Settings)

When setting Realtek format to be 16 bit 44100 Hz, the same as the one of Dorico, Realtek outputs appeared in the Dorico Low Latency driver windows and audio was working OK for both Dorico and Transcribe!

Problem solved, thanks for the outstanding Dorico support as provided by Ulf.

One problem remains … Audio works after setting the output formats as indicated here above, the realtek outputs (Speakers/Headphones) but … plugging an headphone in the jack plug on the docking station doesn’t … headphone must be plugged into the jack laptop plug.

I mentionned this without any details in my first message

More precisely, when plugging the headphone jack into either the docking station or the laptop, a window pops up asking which audio device is to be used (speaker alone, speaker/headphone, etc …) which is what normally happens. Clicking on the headphone field item does work OK when headphone is plugged into the laptop, but the same action has no effect when headphone is plugged into docking station.

That never happened before installing Dorico and using Sibelius on the exact same computer configuration. So this most likely results from setting the the Realtek Spekers/Headphones as outputs of the Low Latency ASIO Dorico driver, leading to a weird impact on how the Realtek driver works with the docking station.

While not a blocking issue, this is still a significant problem because laptop headset plugs are fragile and mostly meant to plug the small jack of low audio quality small headsets, not the big 6.5mm jack of good audio headphones extended with an adapter . If for some reason, the headphone cable puts an effort on the 8cm long plugged big jack and its adapter, the laptop female plug breaks.

This happened to me in the past when using my previous laptop and I decided that I will never ever plug my quality headphone cable into my laptop again.

Using the Realtek ASIO driver from within Dorico would may be fix the problem, but even if it appears in the device setuo it can’t be selected from the device setup dialog of Dorico. No idea why.

Blame it on ASIO (since you have no trouble with Sibelius and that does not use ASIO), but I’d recommend you get yourself a dedicated audio interface such like a Steinberg UR12 or UR22 (or similar from other makers). They are inexpensive, come with excellent sound quality, professional multi client capable ASIO drivers and big jacks. Then you’d have peace of mind.

Unfortunately that’s not a viable solution for me at this time.

Audio interface would have to be attached with one of the 5 USB ports of the docking station, not on the laptop itself (I don’t want tp play with many cables when undocking laptop I carry around regularly).

4 USB ports are already taken: steinberg USB licenser, a SSD drive used to store large stable data (sound samples and video mostly). printer, mouse.

The remaining USB port is used to plug extra things occasionnally but regularly : backup drive, smarphone, Logitech spotlight, Peterson stroboplus tuner, whatever … So attaching an audio interface would have an impact of my workflow.

Being a retired software engineer, I would not blame ASIO itself, but rather its Steinberg implementation, how Low Latency driver grabs Realtek outputs along with how Dell/Realtek/W10 software handles two audio jacks (laptop and docking station) but only one set of speakers (the one on the laptop).

What about using a “donationware” program such as VoiceMeeter? It’s free to use until you feel like making a donation.
https://www.vb-audio.com/Voicemeeter/index.htm

I’ve used VoiceMeeter Banana for a while now and I’ve found it solves a lot of ASIO issues as it allows you to manage multiple ASIO streams at once. In Windows set your default audio output to “VoiceMeeter Input,” and in Dorico set it to “VoiceMeeter Virtual ASIO.” In VoiceMeeter Banana you can specify up to 3 Audio Out devices at once, so select whichever output devices you want to use, including whatever device controls the 6.5mm jack.

With a few programs (like Roon) I’ve needed to use the VoiceMeeter “Virtual Cable” running into one of the VoiceMeeter inputs to get it to work with everything else, but I often have quite a few audio programs all open at once and VoiceMeeter automatically solved a lot of my issues.

Worth a try to see whether it solves problem.

VoiceMeeter looks a bit like the Total RME mixer/dispatcher working exclusively with RME audio interface inputs/outputs

Thanks for the tip

After “w7 ultimate” to “W10 pro” 64bit upgrade Cubase Elements 7; Realtek sound input did not work. Output was OK, but Input apparently did not get through.
Several hours of troubleshooting, including removal of Creative Soundblaster Audigy board software and drivers; (I had more than one audio interface in my PC and wanted to simplify the setup. The Realtek ALC892 audio chip’s many channels should be enough.) A change to ASIO4ALL and HW reset rendered all working.

At first I got noisy output, but OK recording input to Audio track.
After tweaking the ASIO4ALL settings, input and output seems fine. :slight_smile:
For detailed Settings, follow this link:

https://drive.google.com/drive/folders/18n6RbmxdayRT8LY4jokGN2gnlyzPq0xj?usp=sharing

I probably would have preferred the Blue “Line In” input with my equipment, but with “Microphone Boost” it should be OK.

/ EjS