Audio dropouts on new build - clean install

Happy New Year to all.
I started a new pc build a few days ago to migrate from a Dell i5 laptop running win 10 home with 8gb ram. Audio interface is rme babyface pro fs and was using cubase 10 and 10.5 with no problems, besides cpu and memory high usage.

New pc is a ryzen 5 3600xt, with 16gb, 500gb M2 ssd and a 1650 graphics card. New from scratch.
The problem is
I lose audio every five, six, 10 seconds or so from one of the playing tracks being either audio or midi. The dropout is for a fraction of a second. Every dropout happens randomly i.e. is not associated to a particular track. It happens with a 10 track song or a 30 track song.
It does not happen though when an imported song is placed in one track. That will play flawlessly. It happens only with recorded tracks.
I have tried many tricks, including changing from cubase 10.5 to 10.0, replacing rme’s drivers with older version, fiddling with motherboard’s stupid RGB settings, changed buffers from 512 down to 64.
The dropout are not the ones I knew when I was working on a piece that was heavy on the cpu and memory. I know how these sound. These are …loss of sound, loss of output. The rme does not receive anything on that instance.

Any help will be appreciated.

I would suspect this is not a Cubase problem. If you put the buffer from 512 and down to 64 on your RME card you should get more audio problems - not less

Google a program called Latency Mon and download that program, install and run it. It will tell you which drivers are using the most latency. Your problems could be related to anything from USB to wifi to graphicscard drivers to chipset etc.

try Latency mon and see if you can figure out what is causing the problems. If you get less the 100 you have plenty good latency, but also the program will tell you if have acceptable latency.

PC laptops can be a real pain to get working with low latency in my experience

I had no problem with 512, or anything else, whereas I did if changed those values to the old pc.
This new PC is NOT laptop. It’s a proper desktop one.

Right now I am testing the on board sound card (realtek) and I do get the same dropouts plus clicks.

If it happens with two sound cards then who is to blame?

Just ran latency mon

It says
your system appears to be suitable for handling real-time audio and other tasks without dropouts

Did you enable the “optimize windows settings” in the audio settings page?
This makes sure that the CPU is running at 100% constantly via the energy management of Windows.

yes I did. It was one of the first

ah cool you migrated from a laptop. I ran a 3800Xt cpu with an RME card stable 5 ms latnecy no dropouts whatso ever. are you sure you have picked the correct ASIO driver in Cubase? since you have no latency issues it should be a very good chance for a quick fix. That you have selected the RME Asio and not the generic low latency?

I have lived and tolerated low latency with previous computers. This kind of dropout is not like those.
I said before that changing from 512 to 64 brings no latency problems like those I know.
This is something new.
Of course I selected the rme asio. It brings up rme’s control panel from within cubase

I would check to see if there is an update for the motherboard bios

MB is a very new model. Bios date is 23.10.2020

After a thorough search and testing I found that it was a plugin that caused the problem.

https://www.cakewalk.com/Products/CA-2A

At least this triggers some kind of problem on something else resulting in the dropouts. Whenever I removed it the problem was gone.

I am coming back on this with a video
My new pc build (Ryzen5 3600xt, nvidia 1650, 16gb, rme babyface pro fs), running cubase 10.5

After thorough search I found that the cause is a plugin by Cakewalk, the CA-2A levelling amplifier (or compressor).

In the included video first you hear the drop outs with the plugin enabled and then without it.

I don’t know if it has to do with something else, but one thing is for sure: the problem disappears when the plugin is away.
I have to say also that this never happened with my old setup which involved the same components, but the new pc.
I have been using this plugin for more than 3 years, and for almost one with the RME on my previous computer, with never any issue.

Now I have to use another compressor instead.

What could be causing this?

I had Cakewalk installed and various cakewalk plugins crashed Cubase so I just don’t use any of them anymore. Mine runs totally smooth without them at 64 sample buffers and just about any other plugin I try. That was on my older i7 pc. I haven’t tried on my i9 as I no longer have cakewalk installed. I use the Babyface Pro FS and the latency at 64 is brilliant. Even at 128 it is better than my last interface at 64.