Audio drops out and in when switching tracks

In one specific project, when i select another audio track, or when a midi/instrument track is selected and then select an audio track, sound stops and resumes. Normally this only happens when adding a VST plugin or adding an audio or instrument track, but now it does that every time while playing.
I tried importing all audio tracks into a new project, however this doesn’t solve the problem. Also, i am not using any third party plugins on these tracks.
This is a strange problem since all my other projects do not have the same problem. Any thoughts?
I am on Cubase Pro 11.0.20, W10

Temporarily disable ASIO Guard and see if that stops track switching dropouts. If it does, it may be one (or possibly more) Steinberg-based VST plug-in(s) used in this particular Project. In this case, you could check to see if disabling ASIO Guard on an individual (or more) VST plug-in, via the Plug-in Manager, will isolate the culprit(s). Don’t forget to reinstate the global ASIO Guard before disabling individuals via the Plug-in Manager.

1 Like

Or disable selecting a track arms it for recording in the prefs.

1 Like

This happens time to time w/ certain updates. Some just decide to snafu cubase and glitch my audio when switching tracks. IDK why but it comes and goes only after a another update comes out…it’s weird.

I thought it was just me…

1 Like

Yes! I find that it mainly stems from a PC background processes (Mainly Windows) and USb power settings “Waking Up” that cause a hiccup. Also if you have multiple tracks playing back and try to perform and edit a function in a resource heavy VST’s. That’s why offline processing is so helpful.
Once I did some optimization, the issue happens very infrequently now.

1 Like

Thanks to all for your thoughts! I tried all suggestions.
In my case, the solution (which is actually a workaround) is to turn off “Enable Record on Selected Audio Track” under Edit->Preferences->Editing->Project&MixConsole just like @vinark said.
The problem started occurring after i updated Cubase Pro from 11.0.10 to 11.0.20.
Still, i wonder why this occurs only on certain projects…
Again, thanks for the help, people!

Sorry answered the wrong message.

This is way Cubase always has worked. It compensates for latency and depending on how much latency the new plugin adds (if any) there can be dropouts. How severe depends on your asio buffer and additional latency added by plugins in the project. For example a limiter with look ahead on the master bus can add loads of latency. That’s why bypassed plugins keep their latency, to be able to do A B comparison without dropouts.

Thanks for your reply, although i think you are describing another problem.

Yes sorry my threads got mixed up.
Record enabled tracks are using real cores and do not use AsioGuard. Tracks that are not record enabled use AsioGuard (additional playback buffer) and Hyperthreading. So there is a few things getting shuffled around when record enabling a track. I don’t know if latency gets recalculated, that could be the reason that some projects are more affected than others (mentioned in my previous post)

1 Like

My opening post is not entirely correct anymore, read on for a better description of the issue.
It happens on all projects which have been saved in 11.0.20.
Anyway, this is annoying and embarrassing when you are tracking with clients. I would really like to see it solved. So once more the description:

  1. Play a project with two or three audio tracks (no plugins)
  2. Arm an audio track for recording
  3. Audio and GUI stop when arm-button is pressed
  4. Audio and GUI resume

@Martin.Jirsak could you please have a look why this suddenly happens in 11.0.20 ?
I already tested this on different systems with different ASIO hardware and different projects. All have this issue…

Hi,

The audio drop-out is known issue. When you enable Record for the track, the track switches to the “real-time” mode. It’s like this for very long time.