Audio export not working [Win10] after installing Update 3.0.10

Hi guys, so sorry to bother you again.

Since the udpate to Dorico 3 the export audio does not work properly (using the most recent Noteperformer).
Neither mp3 or wav Audio export creates a file, only a now empty folder where the audio export would usually located…

The playback within Dorico itself though works just fine and without any problems!

[Windows 10, 64gb RAM PC - all recent updates installed]

Thanks in advance! :slight_smile:

Does this happen for any project? Do you have a video attached to the project? Is the export successful if you use the HSO+HSSE playback template?

Can you attach a project that shows the problem?

Hi Paul, no video attached to either project.

The export seems to work with older files I have not edited in the “updated” (= Update from 3.0.0 to 3.0.10) Dorico 3 version, but not in the ones I have worked on after installing the update.

Have not tried the HSO+HSSE playback as I have never used it previously yet.

*edit: I don’t know why, but I can’t attach a Dorico file here as attachment, so I’ve quickly put it in the Dropbox:
https://www.dropbox.com/s/oufo0532yd0d8kd/Mussorgky%20-%2005.%20Ballet%20des%20poussins%20dans%20leurs%20coques.dorico?dl=0

Dear bpe-music,
You can attach Dorico files here, but you need to :

  1. turn the playback template to Silent to make the size way smaller
  2. zip the file (or simply add “.zip” at the end of the name of the file) so that it is accepted.

I’ve found the problem - it’s because the long project name and flow name is causing the filename to be beyond the default system limit of 255 characters. It’s trying to create the file

\Flows from ORF Award Musik 2019\Mussorgsky - Bilder einer Ausstellung - 5. Ballet des poussins dans leurs coques\Mussorgky - 05. Ballet des poussins dans leurs coques - Mussorgsky - Bilder einer Ausstellung - 5. Ballet des poussins dans leurs coques.mp3

Which is long. We don’t currently have the ability to customise the filename and path arguments, but you should be able to export it just by setting the ‘Export to’ folder to something at a higher level, eg c:\export. Or rename the file to something shorter.

Thanks a lot, Marc :slight_smile:
I will try that out next time.




I see, thank you very much for clarifying.
Is there any way I can change the default name of the to be exported audio file and also NOT to create a new folder for it (like in e.g. Sibelius)?

No, there’s no specific control over that at the moment, though I anticipate we will add further control in the future.