Audio issue - No sound from other programs

Actually two issues. First when I tried to search the forum for this issue I tried “Audio issues” and got no results due to the terms being “too common.” I tried many other variations and it always either returned no results or ignore the most relevant terms and returned useless threads. NOT VERY HELPFUL!

My real problem is that when Dorico is running, no other program (youtube for example) will produce any sound. So if I wanted to watch the tutorial videos I have to exit Dorico and then restart it afterwards. I find that annoying and limiting. Any thoughts or suggestions?

That’s right. Dorico seizes the audio engine (at least in some computers). If your were exporting audio, you would probably not want other programs to be able to interrupt that.

It was an unpleasant surprise when I first discovered it, but you can try turning it off in Edit > Device Setup > Device Control Panel.
device.png

If you don’t have a multi-client ASIO driver, then this is unfortunately the consequence. The forthcoming 1.0.10 update will have an option in Preferences to release the audio device when the application goes into the background (unless it is in the middle of playback, in which case it will retain ownership).

This thread explains a similar problem that I have had in using other audio applications when Dorico is open. It is obviously linked to https://www.steinberg.net/forums/viewtopic.php?f=246&t=105569

I suppose it could be avoided by having an option to turn off loading of audio playback in Dorico. This would be quite acceptable to me, as I often write music in silence! :slight_smile:

David

Dorico Seizes Sound Engine / Card / Device, No sound on other programs or apps when using Dorico, remains seized after closing:

Click Edit
Click Preferences
Scroll to bottom, under “Play” tab
Click “Suspend audio device in background”
Click Apply

What this means is when you minimize or exit out of Dorico, your other programs will be able to use audio. Thanks to Daniel for above pointing this out as workable in the update, I made the post to be explicit for anyone who has the same issue and is worried their computer (which may, as in this case, be 2 days old) has a problem.

The secondary issue I was having was that upon closing Dorico, the sound was remaining “seized.” Now it unlocks the audio upon closing. Note that if you bring up Dorico to exit out of it, the audio will seize again while you are doing just that, but upon closing if you reload your webpage or restart your media player it should hopefully work like it does for me.

I would suggest not using the Suspend in Background option unless as a last resort, as that may cause other problems. What I would try first is ensure that you are using the ASIO Generic Low Latency Device. Then open the ASIO Generic Low Latency Device control panel and uncheck the box at the top (something like ‘allow apps to take exclusive control’)

When I try to choose the Low Latency Control Panel, I see some screens flash before my eyes, including some sort of progress bar; but before I can even read what they say, the progress bar completes and the “Control Panel?” screens disappear. There is no chance to observe or make any changes.

Yes, we have a bug here. Because of that, the window of the control panel disappears immediately when you have the option “Suspend audio device in background” ticked. So please un-tick it in the preferences and then the window will stay.

That did the trick. Many thanks.

For anyone experiencing similar problems, you may want to experiment a bit with different drivers - I can run Reaper, Sibelius and Dorico simultaneously (using an M Audio Projectmix IO sound card, Windows 7) by first starting Reaper with the dedicated ASIO driver from the Projectmix, then Sibelius using a generic Windows WASAPI driver and then Dorico with either the built in ASIO special low latency driver (that’s the one that comes with the program) or, occasionally when that doesn’t work, the Projectmix driver. The generic Windows media player still works as well as internet etc.

Sometimes Sibelius freezes but restarting fixes that. Latency in Sibelius is obviously high with the WASAPI driver but I don’t really care.

this worked for me thanks!

I have a meaningful contribution to give in this area and frankly it is a MUST DO. This has solved so many problems in relation to running youtube and a DAW on the same computer. Don’t focus on changing your DAW driver if it is working but instead use your onboard audio driver for all your google mp3 stuff. To do this is fairly simple. Mechanically audio out of your motherboard to a ONE KNOB MACKIE or mixer of some kind and out to your amp. Do the same with your interface. You A B on the KNOB what you want to hear i.e. google or your DAW. Your devices do not conflict and your driver doesn’t get confused as they have but one task and no shifting… this works like butter and is a must do in my opinion. You also can hear on the same speakers so no buying more stuff. Two stereo ins on the knob… just the basic one.
The important thing is that you must tell chrome or whatever.
Left click your audio speaker on lower right and open audio settings and look lower screen and you will see something about telling programs assigning programs… click on it… do this with chrome open by the way so it shows up… and then at the right of chrome you will see the ability to pick realtek or whatever onboard audio you have. It is worth it believe me. Oh you will need some cheap 1/4 cables… short. Amzn has them. Look for “guitar 1/4 cables 1 ft” assuming the knob is sitting on your interface like mine… something…they come like 5 in a pack or something. You need two sets of two if I remember right… plan ahead and look at your connections…and you will need to look how to get from your motherboard into the stereo MACKIE KNOB.
Also…get a flashlight so you can see the back of those small outputs on the motherboard and get your manual so you don’t have to experiment as it can quickly turn into a pain… is their audio or not? … that thing… also make sure the device is enabled on your motherboard and perhaps your device manager. But yes… know ahead of time what your need to plug into so you are not wasting your time and giving yourselves needless headaches. When you get it working and it is not hard it rocks and is the only way to go.