AUDIO NOT PLAYNG IN DORICO 3 AFTER USING HEADPHONES

I cannot access my external Audio card at the moment so I cannot tell how it behaves cause I am not at home.
Yesterday
I opened a project project I had been working on Dorico 2 pro in Dorico 3 pro.
I plugged a headphone to my Mac. Everything was fine.
Today I opened the same project as well as other projects.
No audio is playing during playback or midi input.
Midi input works. I can write music but I cannot listen to any sound from Dorico.
Other softwares play audio regularly.
Recently Dorico crashed, I don’t remember when that was.
Any suggestions, thanks



What if you start a new project (e.g. from piano template) does that also not sound?
And please load that non-sounding project again, then choose from the main menu Help > Create Diagnostic Report.
That creates a zip file on your desktop, please attach it here.

Ulf thank you so much for your help

I tell you what is going on…

  1. I rebooted my computer. This is what I did : I took out of trash a Dorico 2 project that I had previously opened with D3. I launched it. And it played well. Now everything is working fine. Actually I don’t know if this procedure has been really effective or the fact that everything is working just casual.
    Of course I am quite afraid of using headphones again. And that is something that I will massively need to do in the very next ten days or so.
  2. A strange thing is that as I open Dorico 3 the ‘recent project’ list comes empty. Maybe because of the recent crash?
  3. In any case I have done what you suggested and attached the diagnostic below.


    If that can be helpful and you can follow the development I would appreciate.
    Thanks
    Dorico Diagnostics.zip (383 KB)

Well, I had a look at the logs and from that perspective everything looks normal. I suspect, that with the headphones went wrong on a OSX level where we have no insights.
However, I noticed that you also do have a Presonus AudioBox. Why don’t you use that one? I’m sure it also has a headphone jack.

HAPPENED AGAIN AFTER A BLUE TOOTH DEVICE PAIRING WITH ANOTHER DORICO 3 FILE.
Diagnostic below
Dorico Diagnostics.zip (374 KB)
Just tried with the trick I described above. Seems to be effective. But I would like not to find myself in these circumstances.

reply to …
‘’ Well, I had a look at the logs …’’

Yes, when I’m home I (can) use the Presonus Audio Box with or without headphones… I can’t when I am on the road as in this period …
Please try to have a look at the other Diagnostic… It seems to exist something wrong between Dorico 3 and MacOs 10.14.6.
Something that has never happened with Dorico 2.
I mean while using cable headphones, bluetooh headphones (Bose Noise Cancelling) or bluetooh devices ( AUKEY EP-B40S).
I feel my trick is not enough. Well enough, it can restore the system (that is something, of course).
Still we cannot use headphones on the road with Dorico 3, and I feel it is a big loss.

Again, in the logs I can’t see anything unusual. In your last session (Oct 19th, 8:30pm to ~11pm) Dorico was always using the Built-in Audio device (Audio incorporato), with no indication that ever some other audio device was selected or even tried to select during that time. If the sound went away during that period it is then not Dorico’s fault, but must be on the operating system level where Dorico has no influence on.
If you want to work this out, then you need to provide a detailed description of what you are doing. And with detailed I mean really detailed, i.e. step by step what you are doing (even best with a time stamp) and what is happening. I guess you don’t have the time for it, but sorry, otherwise we can’t help you.

Ulf thanks for your reply. I see this is a big issue between Dorico and Mac Os new computers as mine. I received this answer from DOrico support (wich unfortunetely is always quite late in answering) …
Problem
When using Dorico (or other Steinberg ASIO hosts) with one of the latest Mac models, it is not possible to switch between the built-in speaker and the headphones on the fly by simply connecting a headphone. In the host, “two” “Built-in audio” options are available instead of the previous one.
Cause
The latest Mac models (from 2018) contain a built-in audio sub-system that is different from prior Intel HDA (High Definition Audio) architecture in Macs. Built-in audio functions are handled by a new component, so that the built-in audio hardware is now ‘looking different’ to audio apps running on the system. Among other things, it provides an independent built-in speaker and headphone output selection as a feature, which cannot be used correctly by our ASIO hosts at the moment.
Solution
Until we come up with a permanent solution, we suggest to create an aggregate device in the Audio MIDI setup (Applications - Utilities). See this link for details.
https://support.apple.com/en-gb/HT202000

The newly created Aggregate Device can then be selected in Dorico Preferences.

In fact the latest versions of the CoreAudio2ASIO component that Dorico (and Cubase etc.) uses to interface with the Mac’s built-in audio hardware provide support for the updated audio hardware in the new iMac Pro and MacBook Pro computers. Provided you see the ‘Input/Output Configuration’ section of the CoreAudio Device Settings window (which you get to by clicking Device Control Panel in Dorico’s Device Setup window), you’ll find that Dorico can automatically switch between them if you choose ‘Automatically configure devices’.

I’ll check it out, thanks Daniel

I’m not seeing this new Input/Output configuration section. How does one get to this screen?
device control panel.png

You need to have the ‘Built-in Output’ device chosen in Edit > Device Setup.

Well, I get that configuration but it just doesn’t work at all.

I give up. I can use my AirPods in every other Audio app except this one unless I use a workaround. My current workaround uses Loopback from Rogue Amoeba.

When I try to use Dorico directly, it shows two AirPods selections. The first is the input (16KHz sample rate) and the second is the output. I select the output and it jumps to 48KHz. There is no possible selection for 44.1KHz. On another machine it shows both 44.1KHz and 48 KHz so it’s not the AirPods. And it works on this machine using other apps. So something is still not right with Dorico core audio driver for at least this machine.

And even with 48kHz it does not work?
Can you attach a diagnostic report?

Here’s the report. Starting playback it turns the play icon to a stop sign and just sits there not advancing the playhead.
Dorico Diagnostics.zip (666 KB)

Thanks for the data, Dave. I still do wonder though…
So the logs tell me that you have Built-in Audio (44.1, 48, 96kHz), Loopback Audio (44.1kHz) and your Air Pods (16, 48kHz).
The supported samples rates are reported via our CoreAudio2ASIO component.
The most recent log file shows, that you wanted to switch from Loopback Audio to AirPods.
But they don’t have a common supported sample rate. Maybe that is the problem.
What if you change to Built-in Audio, set it to 48kHz and then to your AirPods, does that work then?
Also, you say that the playback does not work, but how about if you open the HALion Sonic SE editor window
and click with the mouse on the on-screen keyboard, does that produce sound you can hear via AirPods?

This does indeed work. Thanks for that idea.

To follow up. It’s still not difficult to hang Dorico up even though I’m only using 48KHz everywhere. So there is still something funny going on. It doesn’t switch back to built-in If I disconnect the AirPods. It just hangs after crashing the VSTAudio Engine.
Dorico Diagnostics.zip (630 KB)

Yes, but looking at the contained crashlogs, that’s a different issue. You know, as already discussed in many other threads, we currently have a general crash issue in the audio engine on Mac that may happen at any point in time. It’s related to the copy protection and our eLicenser guys currently put everything else aside and try to solve this issue. It has top priority, because we know it is very annoying and affects so many users.

OK. Thanks…

BTW, I change Loopback sample rate in audio midi to 48KHz and so everything is now 48KHz. Seems pretty stable so far. I also changed the sample rate in the VST (Pianoteq) I’m using to 48KHz.

So for this case at least it is working much better.

I don’t know why this Mac is giving me only 48KHz for the AirPods. I get 44.1KHz and 48KHz on my other machine. Must be the T1 chip or something.