Audio playback speed is too fast


I am new to cubase. I have figured out how to record a guitar piece but when I listen back it is extremely fast, ie a 15 second piece plays back in 2 seconds!! I am happy with the audio buffer settings and have tried adjusting the tempo but nothing changed. Urgent help required please.


It is likely because you are importing a file with a different sample rate. Go to pool check the clock and change accordingly

It also happens to me when my interface fails to change the sample rate as asked by the project. Then I go to Project settings dialog and see in yellow “Unsupported sample rate”. Then I choose the right sample rate.

Try this: reboot computer start Cubase and new project and try to recreate what you are doing,. It sounds as if you have more than one application using audio at once, or you didn’t import the audio. Both those things can cause audio to playback at a different sample rate.
Other than that, we need screenshot of Project settings and Audio Pool I think.