Audio pops in Dorico Playback


I’m encountering an issue with audio popping in Dorico during playback. I’m on Dorico Pro 4.2 running NotePerformer 3.3.2 Apple Silicon beta (it also occurs with NP 3.3.2 Intel with Rosetta). The popping occurs minimally upon regular use, but it increases dramatically if I have other apps running. Even further, if I click away from Dorico into another app while the playback is running, a lot of popping occurs until I switch back to Dorico. I have noticed it most with web browsers.

I’d never had any issues with popping on Dorico until switching to Apple Silicon, so I’m wondering if this is just AS growing pains. I’ve also noticed some popping with both Dorico and Pianoteq while sharing audio over Zoom, so maybe that’s related.

MacBook Pro 16 in. (2021), M1 Max, 64GB RAM, MacOS 12.6
RME ADI-2 Pro FS R Black
CalDigit TS3+ connecting 3 monitors and all peripherals except DAC
OWC Express 4M2 for samples (plugged, but not in use with Dorico)
Using RogueAmoeba SoundSource

I’ve attempted the following troubleshooting steps:
Switched DAC to Steinberg UR24C, no change
Ran without SoundSource, no change
Changed ports for DAC, no change
Run Dorico/NP in rosetta, no change
Switched playback to Halion SE, no change
Tried setting sample rate to everything between 41.1-96, no change
Tried buffer at 512 and 1024, no change
Tried “High Precision” mode on audio device, no change

Any idea what might be going on?


Normally I would not expect such issue on a system like yours. But before digging deeper into it (which will become quite arduous), let’s try something simple. Please open the Dorico Preferences dialog, choose the Play tab and scroll all the way down to the Advanced Options. Unfold the item and then switch off ASIO Guard (and relaunch Dorico.) Do you then still have the pops?

1 Like

I don’t have a Mac, but what ASIO are you using? I could not see it in your list.

Thanks for your replies! @Andro I tried it with both the RME ADI-2 Pro FS R (a USB DAC) and the Steinberg UR24C. If I’m not mistaken, both use CoreAudio on MacOS.

But, I think the problem may be solved… @Ulf , I checked the ASIO Guard setting, and it was already turned off (I don’t remember when I did that), so I tried turning it back on and restarting Dorico — this seems to have fixed it! I haven’t been able to reproduce it again, at least with my initial tests. If it comes back, I’ll update the thread.

Thanks again!

1 Like

I have the same problem.
I am on a Laptop PC, Win10 Pro, 64bit, Intel i5, 16GB RAM.
After upgrading to Dorico 4.3, Dorico does not recognize my onboard Realtek Audio drivers.
I can’t choose them in the “Device Setup” dialog.

Hi @carstencoach , you need to go to the Device Setup, in there click on the Control Panel button and in the upcoming window tick at the top the option about exclusive access. When you do that also the Realtek will appear in the list of output ports again.

It might be that the Device Setup dialog does not update the output list immediately after you close the Control Panel. Should that be the case, close the project once and reopen and it should be fine again.

Hej Ulf.
Thank you. Everything is working fine now.
Christmas Wishes Carsten Coach

1 Like

Thank you! Wishing you and everyone else here, too!

Hej Ulf.
Is there another way of handling the audio driver problem?
Because right now, I can’t get Dorico to start, when using another program for a while.
It gets stuck at “Initialising audio…”

Try the FlexASIO driver. It’s available for free and quite good especially in shared mode.

I’ll try that. Thank you.