Audio recording overlap issue

I’m really not liking the new behavior of how audio is recorded in C6. Let’s say I record a guitar track, get a good take but make a mistake, I set my loop to two measures, cut out the mistake (let’s say it’s half of the last measure of the loop), hit record and replay that part so it’s good. In C5 this worked great, in C6 what happens is that the new recording replaces the old recording completely. So now I have to go back into the first take, extend the end position of the wav to cover up to where I want the new part to be, where as in cubase 5 all I had to do was shorten the silence out of the new take and crossfade. I tried changing the audio record mode in the transport bar but it doesn’t change that aspect of recording. Is there any way to do this via preferences that I’m not aware of? Also can I set it so it automatically removes overlaps from entire takes without me having to click the little drop down menu on the tracks? Thanks so much!