Audio Records Early... Midi is Fine


I see many posts for midi somehow getting shifted early in relation to the click/timing. Luckily I don’t have that issue but I do have an issue the looks the same as the midi issue but only on audio tracks. Over the years I’ve seen a few others who have asked about this but I don’t see a fix for it. So, for me, the only fix I can do is basically the same as the early midi issue. Meaning I must either move the audio recordings slightly to the right to match the midi (which is on time) or move the midi sightly left to match the “earliness” (if that’s a word) of the audio. The “fix” I use depends on the complexity of the project and which type of track would seem easier to move.

When I was able to open old projects in the version of Cubase they were created on I saw that this issue was not there in CB LE4 nor do I remember seeing it in the early CB 7 series. It is there in projects created in the later CB 7, 7.5 and 8 series.

I am recording all my audio thru a 2007 vintage PreSonus Firebox and I am using the latest (and last updated) driver that was released years ago for that interface (it is no loner supported by PreSonus).

My intentions are to purchase a new audio interface soon. Mostly because I want to get on board with Windows 10 when it is issued. Of course before upgrading to W10 I will wait until the software for my home studio (like CB) gets certified for it.

So, other than suggesting that I replace the old Firebox, I am wondering if there are any other suggestions that I might try. Really, the only things I have tried are to vary the audio driver values I list below. I’ve tried every combination available on the driver menus and I always end up using these as most things seems to work the best at these settings.

The driver is set follows:
Latency: 8.0 ms
Sample rate: 44.1 kHz
Clock source: Internal

Thanks a bunch folks :wink:

Regards :sunglasses:

I generally use free audio warp on every file…


This did interest me in the past, so, here is a solution…maybe…

Do a loopback test…

-connect the output of your interface to the input

  • play a short snappy transient rich sound on an audio track
    -record that sound simultaneously in cubase
  • see how many samples/milliseconds the recording is off by
  • in prefs - vst audio system, adjust your record latency by this value

That will take care of your audio interface based recording latency…
If it is based on something else, idk…


Edit: how is it with asioguard turned off?


Ill try the loopback test as you described and report back.

Also, no difference with asioguard on or off.

Regards. :sunglasses:

I’m sorry for you OP but I’m glad to see that I’m not the only one facing this really weird issue.
I own an RME Fireface 400 and have the exact same problem.
The only workaround I found is to put the offset on the track to 20ms but it’s really a pain when you are tracking 40+ vocal tracks, and it’s just a bandaid solution for a bigger issue I can’t seem to pinpoint the cause of.

I tried pretty mch everything to test this and the weirdest thing is that it doesn’t occur all the time. On some project everything sounds on time, and in some others this early latency is there, wether I start a complete blank project or one of my templates.

If you find a solution please let me know :

Good luck :wink:

Well… I tried the loopback test as suggested but I was not able to find why the audio is early. :confused:

I recorded (2) guitar takes.

The 1st take was recorded to (2) tracks with asioguard “on”. One track with VST Amplitube 3 connected (but not active). The other with “no vst”.

The 2nd take was recorded to (2) tracks with asioguard “off”. One track with VST Amplitube 3 connected (but not active). The other with “no vst”.

The loopback recordings were done by connecting a guitar cable from my Firebox headphone out to the instrument 1 input jack.

Both of the 1st recorded tracks start 44ms early. Both loopbacks for these tracks start 43ms early.
Both of the 2nd recorded tracks start 42ms early. Both loopbacks for these tracks start 41ms early.

In this test project I also recorded some midi to an instrument track. The midi notes vary slightly but most are 3ms early to 1ms late.

So, the audio latency through my Firebox apparently is 1ms. Not much there to adjust. Right? Or am I missing things that can be adjusted? I’m much more concerned with the 44ms early start time.

Next I am going to try the other ASIO drivers listed in the VST Audio System. There is one named “ASIO DirectX Full Duplex Driver” and another named “Generic Low Latency ASIO Driver”. I am currently using the “Firebox ASIO x64 Driver” that came with the PreSonus Firebox audio interface.

Regards :sunglasses:

Try opening a new project, top left in the bar with quantise/transport etc- (directly under and between File&Edit above)
-“constrain delay compensation” and turn it off. - ( if it is not visible right click in an empty space and activate visibility)
See how that works for you…(with asioguard off)

Maybe your Audio is fine, just the MIDI late? :wink:

Ok, really last post for me for today (no loose ends;))

If thats the case- goto prefs - record- midi- tick asio latency compensation active by default and see if it helps…

Hey ggc…

I tried a variance of your suggestion, meaning I turned on the “constrain delay compensation” (because it is never active) and recorded a few more tracks with asioguard on & off. Basically the same results with the audio starting about 40ms early. Also tried your midi suggestion…no difference there either.

Again, thanks a lot for the suggestions. One of these days I will try the other audio drivers to see if there is a difference. Man, I have been living with this for so long now that the “moving” of the midi or audio tracks are part of my normal routine. Oh well. :wink:

Regards :sunglasses:

Hi, I’m having the same problem in cb 10.5, audio records fine in 8.2. Just wondering if you ever got an answer for this, thanks

Sorry, no answer. I determined that, for me, my audio was recording correctly. It is certain VSTi’s that record late. So I have since created templates that have Instrument Tracks (used with certain VSTi, like ezdrummer 4) saved with a -43ms track delay. This works fine and corrects the issue for me.

Regards. :sunglasses:

was hoping you wouldn’t say that! Just checked CB 8.2 and all is working as it should, CB 10.5.1 is a mess for me, will look into the track delay.
thanks for getting back to me!