Audio records one and a half beets behind the Metronome

I am using a Macbook Pro 8.1 running updated Yosemite as the OS, I have adjusted buffers , turned Asio Guard off and on , used no plugins or processing and every combination I can think of, also tried my UR28M as an alternate sound card, and always the same results.
To Recreate:

  1. Open Cubase session (new or existing)
  2. Arm the track with metronome on
  3. Hit record and count 1 2 3 4 to the metronome
  4. Listen back to the audio and my voice count starts on the 2 + of the metronome.

I do the same thing in Garageband and it is right on the count leading me to think it is not the Macbook or the sound card a Cubase 8.0.10 problem.

Anyone else experience this or have any insight?

As it turns out it was a simple fix given to me by Canadian support wizard Lindsay Warner, many thanks to Lindsay for this and other issues he has helped me with.
I started Cubase in safe mode by holding Command-Shift-Option while opening.
I then chose Disable Preferences and opened a new project. I turned on the metronome , armed the track and counted with the metronome on 2 different tracks and all was well.
Again…thank you Lindsay.