Audio Stutter Only On First Pass Of Freshly Opened Project

When opening an existing project there are very noticeable audio stutters when any major event occurs within the project (ie a new instrument is introduced, a chord track plays for the first time, etc). The audio in between these major events is silky smooth.

The glitches are a one time deal only. If I let the entire track play out the glitches will not occur any more. It is almost as though Cubase is not proactively looking ahead to pre-load significant data. I have raised the disk pre-load to 4 seconds but that did not make any difference. Should I raise this value to some really high value? It seems odd that my current setting of 4 seconds does not work on the first pass but will work on all subsequent passes. Any ideas or tweaks I could implement in the software or registry level?

So I know that Windows 10 is still in a state of flux. My purchase of Cubase was very recent and I already had Win10 installed on my workstation so I did not have the luxury of working on a lower OS. I fully understand that this could be a windows 10 issue and I am prepared to wait for patches etc to address Win10 issues. I am just trying to understand if there is something I can proactively do on my end help to push Cubase to perform on the first pass because after I get past the first playback of the track it is pretty much rock solid from that point forward.

Thanks for any help

Do you use a lot of Kontakt Instruments? They will load initially WITHOUT the samples fully loaded into memory, and background load everything for a few minutes. However if you play the project through, Kontakt will prioritize notes that have been played in the project and load those first, which could describe the behavior you’re experiencing.

I do not own Kontakt.
I am using a plain vanilla install of Cubase 8 Artist.
Primarily using Padshop, Groove Agent and Halion.

Your reasoning with Kontakt seems to apply here but just with different instruments.
It seems as though the stutter occurs at significant points, never just random.
For example it could be the transition from Verse A to Verse B, and that transition may have a drum roll. Or there may be a chord track change. If I am running a 4/4 timing then it will always occur at the the last note of bar 4 and the first note of bar 1.

If let the entire project play, the next time I play the project all the sounds have been touched or loaded and the stutter does not occur anymore. Is there a way to have Cubase load or touch all sounds in a project before I begin rolling it for the first time?

Sorry, very quick, I’m at a gig and on a phone: You loading samples from an SSD?
Benji

I am not using SSD’s
These are standard Western Digital 1 TB SATA drives.

Thanks

Aloha g,

I would say this is most likely.

However a lil story:
I had and older laptop with a 5400 rpm spindle drive in it
that would do the SAME EXACT BEHAVIOR!

Because like you since it would eventually become rock solid, I always
thought it was the small buffer on the slow hard drive having probs.

But I always used the internal built-in audio I/O system with this laptop.

One day I decided to use the USB out into an external audio interface
and wham! the prob was gone. It was not the hard drive at all.
It was the crappy built-in audio I/O system.

You did not say what audio device you are using and

if it is a 3rd party device it would be I good idea to check with the manufacturer
to make sure it can ‘play well’ with W10.

Good Luck!
{’-’}

Curteye:

That avatar had me doing a double and triple take!! Great!

I am not using 5400 RPM drives. They may not be enterprise level drives but I don’t think they are the lowest end drives either. I have another drive in my system too. I am gonna try to load a project from the other drive just as a test too.

I am running on a fairly recent ASUS EVO motherboard of adequate processing power via AMD Phenon processors. My sound device is an older M-Audio Firewire 410. I have had this unit for quite some time and it has served me very well. It is not officially supported anymore. There will never be any new drivers for it. It still does me some justice and I may eventually get into a Roland or Focusrite unit when the dust settles. I am selling my Waldorf XTk and may use some of the proceeds to update my audio device if I have to. However I would hate to wave my finger at the module telling it “be nice or to the recycle bin you go” only to find that a replacement module does the same.

It is boggling because the hardware performs very well after that first iteration of the project. As it stands now I have to load a project put it on loop and walk to the bathroom. By the time I come back it has looped at least once and is rock steady from that point forward…it’s just crazy talk :slight_smile:

Thanks for the help/hints

On another thought: Is there a chance the the HDD is powering down, going to sleep or parking it’s heads? Methinks that could be a behavior introduced by some update?

My PC is basically in a always-on server kind of mode, or rather no power saver features are enabled.
The only time those hard drives ever stop spinning is during a power failure.
I cannot remember the last time I shut my computer OFF.
I may reboot occasionally or Windows update seems to forcefully reboot it in the wee hours of the morning on a regular basis. It never gets powered down purposely.
But even if I had power saving features enabled on the drives it would seem crazy for windows to try and spin them down within only a few minutes of a project being loaded. The timers on hard drive activity should easily be reset when opening a project or continuously working within a project.

All power saving features for CPU throttling and hard drive spin downs are disabled.
The only power saver I keep active is the monitor sleep function after 25 minutes.

Steinberg should have a utility to test system specific timings without Cubase being loaded.

I was thinking to try the open source ASIO driver that are on the net. I think ASIO for all is one of them. I have nothing to lose right?

Thanks

Spinning down drives doesn’t necessarily point to Windows, some (e.g. WD Green) drives have a fairly aggressive parking policy set in the firmware. Just thinking along here… :slight_smile:

b.

That is interesting.
I may have Green drives. I cannot remember what I used when I upgraded my smaller hard drive recently.

I did verify that I have one WD 1TB Green drive.
This is not my primary drive. I use this drive for only one purpose and that is to run scheduled backups to it.
I do not have any files on there that I access directly.

My other main drives are 2 x Seagate Barracuda ST1000DM003 1TB 7200 RPM 64MB Cache SATA 6.0Gb/s drives.

But just to be absolutely sure I pulled the SATA cable from the WD Green disk just to ensure that it was not dragging the system down during a SATA bus poll if attempting to un-park heads or wake up from its reportedly aggressive internal power saving mode. Sorry to report that with the WD drive disconnected the system did the exact same thing :frowning:

It just seems to me that Cubase somehow caches a lot of the track as it moves along for the very first playback. On subsequent playback the caches seem to be readily available and make playback from that point forward very solid. I am making assumptions here though. I do not fully understand the internal workings of the program.

I will keep plugging away at any further suggestions as they roll in. Thanks

If anything, I’m glad to see that I’m not alone with this issue.

Having the same problem on 8 Pro, Windows 10. 7200 RPM HD.

Thanks for chiming in…I was starting to worry I was the only one on this island

Thanks for chiming in…I was starting to worry I was the only one on this island

I get this. One glitch on the first play through, at the first point in the project where a major change in instrumentation occurs. It’s happened on the last three projects.

I have also suffered this - it first happened to me in Cubase 7.5 /Win 8 Pro 64bit. I was hoping that it would have been resolved when I upgraded to Cubase 8 Pro, but sadly this has not been the case.

In my case, it does not seem to matter how many VSTs are in the project, but it always happens when a new instrument section starts for the first time - i.e. an audio glitch and the ASIO monitor/meter spikes. It makes no difference whether ASIO guard is on or off.

It seems a few of us are suffering this issue - perhaps we should file bug reports.

First, I have seen this occasionally from cubase SX to now. I never worry about it to much, except when I did a live show and I had to turn the volume down and play a few notes on the offending VSTi before starting the song.

Does if make a difference if:
You set a really high buffer
Make sure with asioguard set to high the track that causes the issue is not rec enabled or selected
Play a few notes on the offending track before the song starts.

In my experience it is mostly one VSTi that causes this.

If I had to take a stab at it I would probably say that the Halion instrument is the culprit.
But now that I have read your post I will fool around with it to see if I can verify.

If this is a known issue then I think Steinberg should script something that automatically mutes everything and then systematically touches every instrument prior to releasing the project to the operating system or end user. Maybe it does that now but the function needs to be tweaked. Have you ever noticed how VST instruments will play for a very brief moment after exporting a project to a WAV or MP3? It should do something like that. Or how about a “Touch All” button that does it on command, kind of like how the MIDI PANIC/RESET used to work back in the ol’ days.

Hey that is a great idea. It is easy to do ourself when needed. Just a bar (or 2) with one midi note to all or just the offending vsti and the master output muted. Could at least fix the performing live issue, when it is most embarrassing. And in the studio you could set a marker after the startup bars to start your project after the first pass.