Audio stuttering when using HALion Sonic SE

RESOLVED(?): Unchecking “Allow ASIO host application to take exclusive control of selected port configuration” (under the “Device Control Panel” window for the generic ASIO driver) seems to have solved the problem.

I’m currently running the free trial version of Dorico, and while I’m looking forward to digging into it, I’ve had no end of problems getting it to work correctly. I believe I have solved all of them except for this one:

During playback, the audio frequently stutters and sometimes pops, not unlike a CD skipping. Playback does not pause when the sound stops, but continues and the sound just drops back in eventually. The gaps are usually only a quarter second or so long, but can be up to a second or more. It doesn’t seem to matter how much there is going on at the time, as this occurs with as little as just a few instruments with single quarter notes in sequence. Notably (I think), this only occurs when I have “HALion Sonic SE” selected in the VST instruments panel. Switching that selection to “Symphonic Orchestra” makes the audio stuttering go away. However, I don’t really know what to do with that information. I’ve searched quite a bit and dug through settings all over the place (Dorico, the VST audio engine, my system and audio device settings), but nothing has helped. Increasing the setting of “Multi-core” under “Performance” in the VST audio engine settings improves the issue slightly but does not solve it. I’ve tried changing the buffer size of the ASIO audio driver, but oddly, increasing it seemed to worsen the stuttering so I’ve reset it to 10ms. I have also changed the disk streaming/RAM balance to no effect.

My first thought is that my computer simply is not powerful enough to run the VST engine well. However, that seems unlikely as I meet (and surpass, I think) the minimum system requirements. I’m using a two-year-old HP Spectre x360 with an Intel Core i7 -5500u chip and 8GB of RAM. My audio drivers are all up to date (updated today in an effort to fix this).

Very strange your case.

What if you create a project with just one player, is it also stuttering? Because something simple like that even the most crappy computer should be able to deal with. At home I have an old, very low spec laptop (celeron, 2core) and even that one can handle slightly bigger pieces at ease.

Also, could you please zip up the folder C:\Users<your-name>\AppData\Roaming\Steinberg\VSTAudioEngine_64 and post here. The logging data might give us a clue.

Thanks for your time. I created a project with one piano player, and gave him a 4-bar ascending and descending C major scale to play in the left hand. I played it around five times, and it stuttered/skipped about three times total, which is FAR less than other projects. I then added a right hand scale on top of the left one just for good measure, played it around five times, and it stuttered five times I think.

Here’s the zipped folder. I grabbed it after doing the solo piano tests.
VSTAudioEngine_64.7z (171 KB)

Thanks for the data. Still very strange though, as I can see nothing unusual in the log file.

Please try the following, go to Edit > Device Setup. There is a button called Device Control Panel which will open another little window. In there you can change the driver’s buffer size. What if you increase the buffer size? That should improve the stability of the audio system.
Also, from the log files I saw that you have the ASIO4All driver available. What if you choose that one (also in Edit > Device Setup), same stuttering?

You could also try switching your soundcard output to 44.1kHz

Yes, I did try increasing the buffer size, but oddly, that seemed to make the problem WORSE. It was most stable when the buffer size was set to the minimum (10ms) so that’s where I have it set currently.

As for the ASIO4All driver, that’s an interesting story. I tried it yesterday and I think it worked just the same as the regular one (and still stuttered), but I just tested it again a moment ago and this time no sound plays at all. It’s possible I’m remembering incorrectly and it didn’t actually work yesterday, or that I missed a setting somewhere this time.

I don’t seem to have that option. “Playback Devices” > “Speakers” > “Advanced” only has two options under the “Default Format” section: 16 bit, 48000Hz and 24 bit, 48000Hz. It’s possible I’m looking in the wrong place, though. I’m on Windows 10, by the way, in case that wasn’t clear from my computer information.

Edit: Just in case this is useful information, within Dorico, under “Device Setup,” the only option there is “48000,” regardless of which driver I select.

UPDATE: To the best of my knowledge, I’ve resolved the issue, though I don’t understand why the solution works. On a whim, I clicked “Help” in the device control panel for the ASIO generic driver and was directed a .htm page (file:///C:/Program%20Files/Steinberg/Asio/Help/asioglld_ENG.htm). In the middle of the page was this: “On the other hand, working with small buffers can be demanding for the computer. If the audio buffers are too small, you may get clicks, pops or other audio playback or recording problems. In this case, try increasing the buffer size and/or deactivating the ‘Allow ASIO host application to take exclusive control of selected port configuration’ option.”

As I said before, increasing the buffer size had the opposite of the desired effect. This time, I unchecked the “Allow ASIO host application to take exclusive control…” box. All stuttering and popping disappeared immediately. I tested it several times, even with a moderately-sized score, and it never once stuttered again until I re-checked the box. I didn’t bother changing the box before since I thought I had already tried that, but I think that may have been before I tackled this particular problem (earlier I was trying to resolve an issue where I couldn’t get any sound at all).

I suppose I feel that I’ve wasted your time, since the answer was waiting for me on the help page. However, the solution seems counter-intuitive to me; I would have expected checking the box to be the correct setting, not the other way around. If this indeed shouldn’t be happening, then I guess it’s good that I brought it to your attention. But if this behavior is correct and you have a moment, can you try to explain what’s going on to me?

Excellent to hear that it is fixed for you already. Though I never heard of such case before, it doesn’t surprise me.
With that box ticked the audio engine tries to claim the audio device exclusively but it seems that the system tries to reclaim, leaving them in a constant battle.
Since it is a generic driver (working with virtually any sound device) it also can’t take every particularity of a device into account and thus will not lead to best possible performance. For that reason we always recommend to use an external audio interface with a dedicated ASIO driver (e.g. Steinberg’s UR series) which will deliver much more stable performance.

Got it, thanks so much for your time. You guys are great.