Audio track Inserts problem

Hi friends,

With all respect, please answer in a way a quite unexperienced user can understand. I have Cubase SX but my guess is that my question can relate to any version. I really have tried to consult the manuals, internet forums and all and I’m stucked here.

My problem is related to using a couple of Plugins (or is the correct term perhaps “Virtual effects”?) to Audio tracks. The problem as such is that I cannot hear any modulation by the Plugin when the track is Monitored, but when something is recorded I can listen to it and THEN the Plug kicks in. It makes me a bit hopeful as something gets right in the end and that I might have missed some crusial setting that will solve everything. I’ll try to explain and hope I use the correct terms. I’ll send over any sceen dump on my settings of interest if that can help.

My general setup with my Gina3G Sound card and the ASIO drivers works well on the computer. I have no problems recording MIDI tracks with VST Instruments, nor recording a clean Audio signal from a mic or guitar. My first attemt to learn Cubase a couple of years ago resulted in two songs with a lot of tracks and those still play well from the program.

I’ve got a PODFarm Plugin that emulates guitar amps end effects and a trial version of the MIDI Guitar Plug I recently downloaded for testing. They are not listed as optional VST Devices as but listed options as “Inserts” to any Audio track. The very same problem occurs using both of them, so it seems like some setting in Cubase is wrong.

If I create an Audio track and assign PODFarm or MIDIGuitar as an “Insert” I get access to the Plugs interfaces and they’re displayed in the VST Channel Settings window. I connect my guitar to an analog input on the sound card and set the Audio tracks “In” to “IN1” and “Out” to “BUS1”. Cubase recieves the analog signal and if I monitor the track I can hear the clean signal from the guitar. However…

The Plugs interfaces do not recieve the signal at all. Their internal pots don’t react. Not when monotoring the track, not when starting a recording. The track is monitored but I only hear the clean input. But…

When I LISTEN to the recorded Audio track the Plugs GETS the signal and modulates the clean signal just as intended.

So the recording ends up correctly but it’s useless not to be able to hear the modulated sound when recording. I depend on possibilities to test different sounds and to get the “groove” when recording.

I really hope there’s something in this information that tells you more experienced users what’s wrong here. As I said it was a couple of years ago I did my two tracks but I actually used the PODFarm Plug then - and could hear the sound when recording. Can’t remember exactly how but it seems Iike some setting is wrong now. As well as it seems like the Plugs actually works if I get that right.

BTW, the MIDI Guitar plug used on an Audio track is then used to generate MIDI signals out of analog playing on the guitar. That signal can then be recieved by a MIDI track with possiblities to use VST Instruments. This works as well, but ONLY when listening to a recorded Audio track. Quite in consequense as the Plug don’t get any signal to pass unless it is a recorded one.

To put it as a straight forward question (as far as I understand): What might prohibit and Audio track to pass a signal to an Insert when recording, but pass signals that already are recorded?

To get this right will really make my day. Hope you’re willin’ to transfer some useful knowledge.

My best

Hi Michael

It’s a matter of monitoring. If you want to hear what you play with your effects, you need to monitor through Cubase.
I have Cubase 7.5 and different audio interface than you, but the principle is the same.
If your audio interface has mix knob between direct/daw(computer) monitoring, set it fully to daw. (you want to hear the proccessed signal from computer, not the dry clean guitar like you said)
In Cubase check your device setup prefferences.
It’s where you set your sound card, drivers,buffer size, and so on. There should be an option like Direct monitoring or something similar. Make shure it’s unchecked.
You can also check the manual. It should be somewhere inthe chapter about adio recording and different ways of monitoring.

Hope this helps


Thank’s for that most important input but I used monitoring. Perhaps I was a bit unclear but mentioned it. But I’ve actually just stumble over a solution by messing around a bit with the VST In- and Output settings and activating BUS’es. Suddlenly the signal came trugh and (I can’t say for sure) perhaps it was a switch-on to a BUS that made the trick. Thank’s anyway. Problem is solved.